InraPorc®

InraPorc® a été développé par l'INRA - Agrocampus, Unité Mixte de Recherches "Systèmes d'Élevage, Nutrition Animale et Humaine" (UMR SENAH) avec le concours de la Société AJINOMOTO EUROLYSINE S.A.S. et d'autres partenaires. Cet outil permet de déterminer les besoins nutritionnels des porcs en fonction d'objectifs de performances et de simuler les performances des animaux en fonction des apports alimentaires. Le logiciel est structuré autour de trois modules principaux :

  • Le module aliment qui permet de gérer les caractéristiques des aliments et des matières premières servant à formuler ces aliments.
  • Le module truie qui permet de calculer les besoins de la truie en gestation ou en lactation et de simuler l'évolution de leurs caractéristiques corporelles en réponse aux apports alimentaires. Les conceptes ont été publiés dans les Journées de la Recherche Porcine (Dourmad et al., 2005) et dans un numéro spécial de la revue Animal Feed Science and Technology (Dourmad et al., 2008).
  • Le module croissance qui permet de simuler la réponse des porcs à l'engrais aux apports alimentaires et de déterminer leurs besoins. Les conceptes ont été publiés dans les Journées de la Recherche Porcine (van Milgen et al., 2005) et dans un numéro spécial de la revue Animal Feed Science and Technology (van Milgen et al., 2008).

Pour des informations complémentaires, veuillez visiter le site web d'InraPorc.


Types de licences

Pour InraPorc, trois types de licences sont possibles : "évaluation", "éducation" et "complète". La licence d'évaluation que l'on peut utiliser pour tester InraPorc ne nécessite pas d'enregistrement et elle permet de découvrir le fonctionnement du logiciel. Les informations sur les aliments, les matières premières, les profils animaux peuvent être renseignés pour une session mais elles ne peuvent pas être sauvegardées pour une utilisation ultérieure. Par conséquent, toute l'information créée pendant cette session sera perdue en quittant le logiciel. La licence réservée à l'éducation permet d'enregistrer un nombre limité d'informations liées aux aliments et aux matières premières (10) ou aux stratégies alimentaires et aux profils animaux (5). Cette version d'InraPorc est gratuite mais soumise à enregistrement. Enfin, la version complète n'est pas limitée dans son fonctionnement.

La version complète comme la version réservée à l'éducation exige de fournir, au premier démarrage, une clé d'activation valide. En absence d'une clé d'activation valide, le logiciel fonctionnera en mode "lecture seule". La clé d'activation sera inclue dans un fichier de licence (InraPorc.lic), qui vous sera envoyé lors de l'enregistrement. Vous pouvez demander une clé d'activation si vous souhaitez avoir une licence d'éducation (voir le site web d'InraPorc pour les conditions d'utilisation de la version d'éducation). Si vous voulez utiliser la version complète, il faut d'abord remplir le formulaire de commande de licences avant de demander la clé d'activation. Après l'envoi de la commande, nous vous enverrons un (ou des) numéro(s) de licences que vous devrez utiliser lors de votre demande de clé d'activation. Nous transférerons votre commande à Inra Transfert, qui vous enverra la facture. En attendant la réception et le paiement de la facture, vous pouvez demander une clé temporaire qui sera valable pendant 2 mois.


Clé d'activation de licence

La version complète comme la version réservée à l'éducation exige de fournir, au premier démarrage, une clé d'activation valide. En absence d'une clé d'activation valide, le logiciel fonctionnera en mode "lecture seule". La procédure qui indique la façon d'obtenir une clé d'activation de license est illustrée dans une animation Flash.

Pour demander une clé d'activation, complétez les informations d'enregistrement (n'oubliez pas de choisir le type de licence et le numéro de licence pour la version complète). Il est important que ces informations soient saisies en utilisant l'ordinateur sur lequel InraPorc est installé. Si vous cliquez sur le bouton "Automatique", la demande sera automatiquement enregistrée sur notre serveur. Si vous préférez demander une clé d'activation manuellement (ou que vous n'êtes pas connecté à Internet), Cliquez sur le bouton "Manuel". Les informations de licence seront enregistrées dans un fichier InraPorc.lic, que vous devrez soumettre manuellement sur notre serveur.

Après réception de votre demande, nous générerons une clé d'activation et l'inclurons dans le fichier InraPorc.lic. Ce fichier vous sera renvoyé par e-mail et vous pourrez l'enregistré à l'emplacement de votre choix. Pour activer votre licence, lancer le programme InraPorc et ouvrez la fenêtre de gestion de licence. Cliquez sur le bouton "Importation" et indiquez l'endroit où vous avez enregistré le fichier InraPorc.lic.

La clé d'accès est valide jusqu'au 31 décembre de l'année en cours. Une mise à jour du fichier de licence sera envoyée automatiquement aux possesseurs de la version complète. Les utilisateurs de la version d'éducation devront demander une nouvelle clé d'activation chaque année.


Configuration

Général

Le menu de configuration se compose de quatre onglets. L'onglet "Général" permet de paramétrer le répertoire par défaut pour les données. Chaque fois qu'InraPorc est démarré, les données de ce répertoire sont utilisées. Dans cet onglet, vous pouvez indiquer l'endroit où des données d'une simulation doivent être exportées (sous forme d'un fichier Excel). Ces données peuvent ensuite être réutilisées. Dans cet onglet, vous pouvez également indiquer la taille (par défaut) de la fenêtre, la langue et le symbole monétaire. Un logo (hauteur maximale : 120 pixels) peut également être défini ici, qui sera affiché dans la fenêtre principale d'InraPorc.
Un certain nombre de messages d'avertissements peuvent survenir pendant l'utilisation du logiciel et vous avez l'option de ne plus afficher ces messages par la suite. À partir du menu de configuration, vous pouvez réactiver l'affichage de ces messages.

Matières premières et aliments

Sous l'onglet "Matières premières et aliments" les préférences pour le mode de saisie de la composition et de la digestibilité des aliments et des matières premières peuvent être indiquées. La composition peut être exprimée en frais ou relativement à la matière sèche et les valeurs de digestibilité en pourcentage ou en teneur digestibles (par exemple, g/kg). Les valeurs de composition chimique peuvent être indiquées en g/kg ou en pourcentage. Les compositions en acides aminés et en acides gras sont respectivement exprimées relativement au contenu en MAT et en acides gras totaux. L'onglet "matières premières" dans la fenêtre "Composition aliment" peut être caché pour éviter de divulguer ces informations à des tiers.

Truie

Dans l'onglet "Truie", le mode d'expression par défaut pour l'affichage des graphiques peut être défini. Les caractéristiques des stratégies alimentaires appliquées par défaut aux truies en gestation peuvent aussi être précisées à cet endroit.

Porc croissance

Le mode d'expression par défaut pour l'affichage des graphiques peut être défini ici, ainsi que l'expression de l'efficacité alimentaire (c.-à-d., IC ou GMQ : aliment distribué).
La définition de la carcasse (et donc le rendement d'abattage) est variable selon les pays. Pour afficher correctement les variations du rendement de carcasse au cours de la croissance, l'utilisateur doit indiquer la définition de carcasse (par défaut, la carcasse comprend la tête, la langue, les pieds et la queue, mais pas la hampe ni la panne). De même, la définition de l'épaisseur de lard dorsal et taux de maigre dépendent de la façon dont ils sont mesurés et estimés. Les 2 équations fournies prédisent l'épaisseur de lard à 6 cm de la ligne médiane dorsale entre les 3ème et 4ème dernières côtes (à l'abattage) et le Taux de Muscle des Pièces (TMP) comme défini dans l'Union européenne (Règlement N° 1197/2006 de la Commission), mais l'utilisateur peut remplacer ces critères par ses propres équations. InraPorc fonction en interne sur les masses de protéines et de lipides et les équations fournies doivent être des fonctions de masses de protéines et/ou de lipides, ou des teneurs en protéines et de lipides dans le poids vif vide.


Data directory

Dossier de données

Par défaut InraPorc chargera les fichiers à partir du répertoire de données qui est indiqué dans la fenêtre de configuration. Néanmoins, InraPorc peut utiliser des données d'un autre dossier à condition que ce dossier contienne tous les fichiers nécessaires (c.-à-d., les fichiers de type "*.rec"). Si vous souhaitez utiliser plusieurs dossiers de données (par exemple, pour une utilisation en plusieurs langues), il est recommandé que vous installiez ces dossiers de données en utilisant l'outil d'installation que l'on peut trouver dans le répertoire d'installation d'InraPorc.


Matières premières

Dans InraPorc la plupart des calculs sont basés sur la composition des aliments. Afin de ne pas avoir à saisir manuellement les valeurs de composition et de digestibilité d'un aliment, celles-ci peuvent être déterminées à partir de ses constituants élémentaires. InraPorc offre, dans une base de données, des valeurs prédéfinies pour un grand nombre de matières premières utilisées en alimentation porcine. Ces données proviennent pour la plupart de la publication de l'INRA-AFZ "Tables de composition et de valeur nutritive des matières premières destinées aux animaux d'élevage : porcs, volailles, bovins, ovins, caprins, lapins, chevaux, poissons" (Sauvant et al., 2004). Ces données sont soumises au droit d'auteur et restent la propriété de l'INRA et de l'AFZ. Ces données sont confiées pour une utilisation paisible par l'entreprise et sont non cessibles. Elles restent la propriété de l'INRA et de l'AFZ, même si elles devaient être incluses dans ce logiciel. Les données ont été élaborées avec soin et vérifiées. L'entreprise utilisatrice est seule responsable de l'utilisation qu'elle en fera et de leur altération éventuelle au cours de manipulations internes à l'entreprise. Ces données prédéfinies ne peuvent pas être changées, ni supprimées et ces matières premières ne peuvent pas être renommées (elles sont indiquées sur fond gris). Néanmoins, l'utilisateur peut créer d'autres matières premières.

Les matières premières sont caractérisées par plusieurs critères, comme indiquées dans des onglets composition élémentaire, acides aminés, acides gras, minéraux et fibres. Dans sa version actuelle InraPorc utilise les informations contenues dans les onglets "composition élémentaire", "acides aminés" et "minéraux". Les autres critères pourront être utilisés dans une prochaine version d'InraPorc.

L'utilisateur peut enregistrer de nouvelles matières premières dans la base de données, soit en mode création, soit en mode duplication. Les aliments créés par l'utilisateur peuvent être modifiés, renommés ou supprimés et des commentaires peuvent y être associés. Le type d'aliment (par exemple, céréales) peut être indiqué avec les commentaires.

La saisie de données numériques ne peut se faire que dans des zones de saisie blanches avec une police noire, les fenêtres grisées étant réservées aux données de référence ou aux données calculées. Il est important que les informations retenues dans les tableaux soient aussi exactes que possible. Si l'information manque, la valeur "zéro" sera enregistrée par défaut et utilisée par la suite dans les calculs. Différents modes d'expression de la composition alimentaire (g/kg ou % de la matière sèche) et de la digestibilité peuvent être choisis dans le menu de configuration d'InraPorc.


Aliments

Dans InraPorc, la plupart des calculs dépendent de la composition des régimes. Afin de ne pas avoir à saisir manuellement les valeurs de composition et de digestibilité d'un aliment, celles-ci sont déterminées à partir de la composition des matières premières constitutives de cet aliment.

De nouveaux aliments peuvent être introduits dans la base de données soit en mode création soit en mode duplication d'un aliment déjà existant. Toutes les données sur les aliments peuvent être modifiées, renommées, supprimées, et commentées. Le bouton "commentaire" peut aussi préciser le type d'aliment (c.-à-d. pour porc en croissance ou truie), la forme de distribution (farine ou granulés), et le prix de l'aliment.

Les aliments composés sont définies selon divers critères indiqués dans les onglets composition élémentaire, acides aminés, acides gras, minéraux, fibres et matières premières. Dans la version actuelle d'InraPorc, seuls les critères "composition élémentaire", "acides aminés", "minéraux" et "matières premières" interviennent. Dans une prochaine version les autres critères seront pris en compte.

La saisie de données numériques est possible uniquement dans des zones de saisie blanches en caractères noirs, les fenêtres grises étant réservées aux données de référence ou aux données calculées. Il est très important que les informations indiquées dans les tableaux soient aussi exactes que possible. Si l'information manque, la valeur "zéro" sera enregistrée par défaut et prise en compte dans les calculs. Différents modes d'expression de la composition alimentaire (g/kg ou % de la matière sèche) et de la digestibilité peuvent être choisis dans le menu de configuration.


Composition élémentaire des matières premières et des aliments

Composition élémentaire

Dans cet onglet sont indiquées la composition et la digestibilité fécale des nutriments. La composition élémentaire concerne les taux de matière sèche, matières minérales, matière organique (calculée à partir des matières minérales), matières grasses, matières azotés totales (MAT), amidon et sucres. Des coefficients de digestibilité fécale peuvent être définis spécifiquement pour les porcs en croissance et les truies. La digestibilité fécale de l'amidon et des sucres est supposée de 100%.

Les données sont enregistrées relativement à la matière sèche, c'est donc la première information à donner en enregistrant une nouvelle matière première ou un nouvel aliment. Si la composition chimique est exprimée "sur frais", la modification de la teneur en matière sèche s'accompagne d'un changement proportionnel de la composition des autres nutriments. Il en est de même pour le taux protéique relativement aux acides aminés. Si la case à droite de la valeur de MAT est cochée, le rapport entre acides aminés et MAT sera maintenu constant. Une augmentation de la teneur en MAT augmentera alors proportionnellement le niveau de tous les acides aminés. Ceux ci pourront toutefois être modifiés dans l'onglet "acides aminés".

Les valeurs énergétiques (EB, ED, EM et EN) sont toutes calculées en utilisant des équations développées dans notre laboratoire (Noblet et al., 1994). Ces équations sont basées sur la composition élémentaire, les coefficients de digestibilité et le "résidu digestible". Ce résidu, sensé contenir toute la partie fibre, est défini comme la différence entre la matière organique digestible et l'ensemble des fractions digestibles (matières grasses, matières azotées, amidon et sucres).

EB = ((22,64 · MAT) + (38,76 · LIPIDES) + (17,54 · AMIDON) + (16,71 · SUCRES) + (18,58 · RESIDU)) / 1000
ED = ((23,31 · dMAT) + (39,00 · dLIPIDES) + (17,45 · AMIDON) + (16,62 · SUCRES) + (16,61 · dRESIDU)) / 1000
EM = ((20,34 · dMAT) + (39,00 · dLIPIDES) + (17,45 · AMIDON) + (16,62 · SUCRES) + (15,51 · dRESIDU)) / 1000
EN = ((12,08 · dMAT) + (35,01 · dLIPIDES) + (14,32 · AMIDON) + (11,94 · SUCRES) + (8,64 · dRESIDU)) / 1000

En raison de la relation étroite maintenue, dans InraPorc, entre les nutriments digestibles et les valeurs énergétiques, celles-ci peuvent être employées pour corriger les coefficients de digestibilité. Après cochage de la case correspondante, l'utilisateur peut corriger les coefficients de digestibilité en partant d'une valeur connue d'ED, EM ou EN. Ceci corrigera alors les digestibilités de la matière organique, des matières grasses et des matières azotées totales (les digestibilités de l'amidon et des sucres resteront 100%). Pour plus d'information concernant les calculations des valeurs énergétiques à partir la composition chimique, veuillez consulter EvaPig.

Le module truie d'InraPorc travaille par défaut avec la valeur de l'EM, les valeurs de composition élémentaires et de digestibilité ne sont pas utilisées directement. Le module porc en croissance, par contre, travaille par défaut sur une base nutriments digestibles. Pour ce module, il est essentiel que les valeurs de digestibilité soient aussi précises que possible.


Composition en acides amines des matières premières et des aliments

Acides aminés

Dans les modules "truie" et "porc en croissance" du logiciel InraPorc, l'apport en acides aminés essentiels peut potentiellement limiter les performances. Aussi, une information précise pour chacun des douze acides aminés essentiels est nécessaire pour que ces modules fonctionnent correctement. Le mode d'expression pour les acides aminés est basé sur la digestibilité iléale standardisée. Avec ce mode d'expression, les valeurs de digestibilité sont corrigées pour des pertes endogènes basales qui théoriquement varient proportionnellement à la consommation de matière sèche. Pour une discussion plus approfondie sur les différents modes d'expression de digestibilité des acides aminés, l'utilisateur se référera aux Tables de composition et de valeur nutritive des matières premières destinées aux animaux d'élevage (Sauvant et al., 2004), AmiPig ou EvaPig.

Selon la préférence de l'utilisateur (voir le menu de configuration), la valeur de digestibilité iléale standardisée peut être saisie comme un coefficient de digestibilité ou une teneur digestible. La valeur correspondante exprimée sur une base de digestibilité apparente est également indiquée. La composition de la protéine idéale (c.-à-d., la teneur en acide aminé exprimée relativement à la lysine) est donnée sur une base de digestibilité iléale standard et totale.

Différents critères concernant les acides aminés sont par ailleurs calculés. Ainsi, la cystéine pouvant être synthétisée à partir de la méthionine et la tyrosine à partir de la phénylalanine, des valeurs cumulant la somme de ces acides aminés sont indiquées. De même, le rapport tryptophane/acides aminés neutres (phénylalanine, tyrosine, isoleucine, leucine, et valine) ainsi que le rapport azote des acides aminés essentiels/azote total sont rapportés. Ces deux derniers critères ne sont cependant pas actuellement exploités dans les modules de simulation (cf. Sève, 1994 et Lenis et al., 1999 pour une discussion sur ce sujet).


Composition en acides gras des matières premières et des aliments

Acides gras

La composition en acides gras des aliments n'intervient pas pour le moment dans les modules de simulation. Le manque d'information (c.-à-d. laissant des valeurs à zéro) relatif à ce critère sera donc sans conséquence. Dans une prochaine version d'InraPorc, cette information sera nécessaire pour estimer la composition en acides gras de la carcasse. La composition en acides gras de l'aliment et des matières premières alimentaires dépend de la contribution relative de chacun des acides gras et aussi du rapport acide gras/lipides. La fraction restante est constituée du glycérol, des acides gras non identifiés et de la fraction non lipidiques extraite par l'éther. Divers critères indicatifs pour la qualité des acides gras sont fournis. Les données sont exprimées par défaut en pourcentage des lipides totaux. Par conséquent, la modification de la teneur en lipides de l'aliment changera proportionnellement la teneur en chacun des acides gras de l'aliment.


Composition minérale des matières premières et des aliments

Minéraux

La composition minérale des aliments n'intervient pas directement dans le calcul des performances des truies et des porcs en croissance. Bien que pour le phosphore le besoin soit calculé, un apport insuffisant de cetélément n'aura pas de conséquences sur les performances (simulée). Pour quelques minéraux (P, Ca, K, Cu et Zn), l'ingestion est comparée à la rétention corporelle (basée sur la rétention minérale moyenne exprimée en fonction du gain moyen quotidien), ce qui permet le calcul de l'excrétion minérale. Le manque d'information ou une information incomplète sur certaines matières premières (c.-à-d., laissant des valeurs à zéro) peut sous-estimer la teneur en minéraux de l'aliment et par conséquent sous-estimer l'excrétion minérale. Si InraPorc est employé pour estimer l'impact environnemental de la production porcine, l'utilisateur doit donc s'assurer de la précision de la teneur en minéraux de l'aliment.

Une distinction est faite entre les macroéléments (Ca, P, Na, K, Mg, Cl, et S) et oligo-éléments (Cu, Zn, Mn, Fe, Se, Co, Mo et I). L'équilibre cations-anions et l'équilibre électrolytique sont calculés à partir des macroéléments.

Plusieurs critères supplémentaires relatifs à la digestibilité et au métabolisme du phosphore sont indiqués. Le besoin en phosphore est calculé sur la base de phosphore digestible. Des valeurs différentes peuvent être fournies pour des aliments en granulés ou en farine (selon la dénaturation de la phytase endogène). Ces informations ne sont pas exploitées dans la version actuelle, elles pourront l'être dans de prochaines versions d'InraPorc. L'activité phytasique des matières premières peut être saisie, mais n'est actuellement pas utilisée par le logiciel. La phytase microbienne peut être saisie comme une matière première. Il est recommandé que chaque niveau de phytase (c.-à-d., 500, 1000, ou 1500 UI) soit identifié comme une matière première à part. Dans ce cas, des valeurs différentes de phosphore digestible peuvent être attribuées à chaque niveau de phytase.


Teneur en fibres des matières premières et des aliments

Fibres

Dans la version actuelle d'InraPorc, la composition en fibres des matières premières ou des aliments n'intervient pas dans les calcul. Les fibres sont définies par leur teneur en cellulose brute, en NDF, ADF, ADL et la teneur en fibres totales (TDF).


Composition en matières premières d'un aliment

Matières premières

Les valeurs de composition chimique et de digestibilité d'un aliment composé peuvent être saisies manuellement. Cette information peut également être calculées à partir des matières premières constitutives de l'aliment et de leurs valeurs de composition chimique et de digestibilité. Jusqu'à cinquante matières premières peuvent être utilisées pour constituer un aliment donné. Ces matières premières peuvent être sélectionnées à partir d'une liste et leur taux d'incorporation dans l'aliment doit être précisés (exprimée en g/kg d'aliment). La teneur en matière sèche de chaque constituant pourra être modifiée pour la formulation (le taux de matière sèche ne sera pas changé dans la base de données des matières premières). Une fois que tous les ingrédients sont choisis, la composition de l'aliment est obtenue en cliquant sur le bouton "Calcul". Il est recommandé de faire ce calcul seulement lorsque la somme de tous les constituants atteint 1000 g/kg d'aliment. Lors de la validation de l'opération, les valeurs de composition chimique et de digestibilité de l'aliment seront remplacées par celles calculées à partir des diverses constituants de l'aliment, sans possibilité de retour en arrière. Les valeurs de composition et de digestibilité peuvent ensuite être changées manuellement. Aussi, il n'y a aucun lien dynamique entre la composition de l'aliment et les constituants de l'aliment. Ceux-ci servent uniquement à faciliter la définition de la composition de l'aliment.

Le bouton "Graphiques" montre graphiquement la contribution de chaque matière première dans l'aliment. Par exemple, on peut ainsi représenter la contribution du tourteau de soja à l'apport de lysine digestible dans l'aliment.

Dans des simulations, les quantités totales des matières premières consommées peuvent être affichées.


Coût alimentaire

Pour chaque aliment, l'information sur le coût peut être renseignée dans la base en cliquant sur le bouton "commentaire". Pour simplifier la procédure d'enregistrement des coûts, cette information est également regroupée dans un menu séparé. Seuls les prix des aliments peuvent être enregistrés ; ceux des matières premières ne sont pas utilisés dans InraPorc. Le symbole monétaire peut être défini dans le menu de configuration d'InraPorc.


L'import et l'export des aliments et des matières premières

Import / Export

Pour faciliter l'échange des données concernant les aliments et les matières premières avec d'autres logiciels ou entre utilisateurs d'InraPorc, la version complète intègre une fonction d'import/export. La composition chimique d'aliments et de matières premières peut être exportées et/ou importées sous forme d'un fichier CSV. Le séparateur décimal ainsi que le séparateur de champs (séparateur de liste) sont paramétrés dans les options régionales et linguistiques de Windows. Les données (importées ou exportées) seront formatées selon le mode d'expression des unités défini dans la configuration d'InraPorc. Le fichier CSV peut être facilement lu et modifié à partir d'un tableur tel que Microsoft Excel. Un seul fichier CSV peut contenir à la fois des aliments et des matières premières.

Importer des aliments et des matières premières

Au sein d'un jeu de données InraPorc, les aliments et matières premières doivent avoir un nom spécifique, c'est pourquoi l'importation d'une matière première ou d'un aliment dont le nom est déjà utilisé nécessitera de renommer l'enregistrement. Il est techniquement possible d'importer les données d'une matière première en tant qu'aliment et vice versa. Dans ce cas le type d'aliment (porc croissance ou truie) ou le type de matière première (par exemple céréales) devront être changés manuellement.

Avant d'importer des données sous InraPorc, vérifier les options régionales et linguistiques de Windows (formatage du fichier CSV) ainsi que la configuration du mode d'expression des matières premières et aliments d'InraPorc. Il est donc indispensable d'indiquer les paramètres du mode d'expression utilisé lors de l'exportation si vous transmettez un fichier à d'autres utilisateurs.

Exporter des aliments et des matières premières

Pour exporter des données depuis un autre logiciel vers un fichier CSV lisible par InraPorc, l'utilisateur peut utiliser un fichier CSV existant (créé par InraPorc) ou en créer un nouveau. La première ligne du fichier doit contenir des informations d'en-tête qui ne seront pas importées.

Alors qu'un aliment enregistré dans InraPorc peut contenir des informations concernant les matières premières constitutives, ces dernières ne sont pas incluses lors de la copie dans un fichier CSV. Un aliment exporté ou importé d'un fichier CSV contient uniquement les données de composition chimique de cet aliment.


Module truie

Truies reproductrices

Les caractéristiques générales du module truie ont été publiées dans les Journées de la Recherche Porcine (Dourmad et al., 2005) et dans une numéro spéciale sur la modélistion dans Animal Feed Science and Technology (Dourmad et al., 2008).

Pour réaliser une simulation, les éléments suivants sont nécessaires :

  • Séquence alimentaire
  • Plan de rationnement
  • Logement
  • Profil de performances

Après leurs définitions, vous pouvez réaliser des simulations :

  • Simulation de performances
  • Comparaison de simulations
  • Analyse de sensibilité

Ou calculer les besoins par l'approche facorielle :

  • Calcul des besoins de la truie en gestation
  • Calcul des besoins de la truie en lactation


Séquence alimentaire (truie)

Séquence alimentaire

Les aspects quantitatifs et qualitatifs des plans d'alimentation sont définis séparément. Le choix des aliments utilisés est défini par la séquence alimentaire alors que le niveau d'apport est défini dans le plan de rationnement. Une séquence alimentaire peut être sélectionnée dans une liste, supprimée ou renommée (ceci permet de créer une nouvelle séquence à partir d'une séquence existante). Un commentaire spécifique relatif à la séquence alimentaire (texte libre) peut également être ajouté.

Bien que la structure générale des séquences alimentaires pour les truies reproductrices soit similaire à celle utilisée pour le porc à l'engrais, quelques différences existent entre les deux. En effet, les séquences alimentaires "truies" regroupent trois périodes correspondant aux trois stades du cycle de reproduction : la gestation, la lactation et l'intervalle sevrage-oestrus.

Pour chacun de ces stades la séquence alimentaire est décrite sur la base d'une série de règles successives. Chacune d'entre elles est définie par un mode de fin et un type d'aliment distribué. La première séquence démarre en début de simulation et dure jusqu'à la règle de fin. La seconde séquence est alors considérée etc…. La dernière séquence est valide jusqu'à la fin de la simulation.

Pour les truies reproductrice les règles de fin sont soit une durée (nombre de jours) soit un évènement physiologique correspondant à un changement de stade (mise-bas, sevrage, insémination). Pour chaque règle il et possible de choisir un aliment, une combinaison de deux aliment ou encore deux aliment dont la proportion évolue avec le temps (transition progressive).


Plan de rationnement (truie)

Plan de rationnement

Les aspects quantitatifs et qualitatifs des plans d'alimentation sont définis séparément. Le choix des aliments utilisés est défini par la séquence alimentaire alors que le niveau d'apport est défini dans le plan de rationnement. Le plan de rationnement peut être sélectionné dans une liste, supprimé ou renommée (ceci permet de créer un nouveau plan à partir d'un plan existant). Un commentaire spécifique relatif au plan de rationnement (texte libre) peut également être ajouté.

Bien que la structure générale des plans de rationnement pour les truies reproductrices soit similaire à celle utilisée pour le porc à l'engrais, quelques différences existent entre les deux. En effet, les plans de rationnement "truies" regroupent trois périodes correspondant aux trois stades du cycle de reproduction : la gestation, la lactation et l'intervalle sevrage-oestrus.

Pour chacun de ces stades le plan de rationnement est décrit sur la base d'une série de règles successives. Chacune d'entre elles est définie par un mode de fin et une quantité distribuée. La première séquence démarre en début de simulation et dure jusqu'à la règle de fin. La seconde séquence est alors considérée etc…. La dernière séquence est valide jusqu'à la fin de la simulation.

Pour les truies reproductrice les règles de fin sont soit une durée (nombre de jours) soit un évènement physiologique correspondant à un changement de stade (mise-bas, sevrage, insémination). Pour la gestation et l'intervalle sevrage-oestrus la quantité d'aliment est constante pour une règle donnée. Pour la lactation des courbes types peuvent également être utilisées (linéaire, linéaire-plateau ou curvilinéaire). Ceci permet de définir simplement un plan de rationnement à partir de la consommation initiale et de la consommation moyenne. Le niveau d'alimentation être défini en quantité d'aliment (kg/j) ou d'énergie (ED, EM, EN).


Logement (truie)

Logement

La fiche "logement truie" permet de définir les principales caractéristiques de logement pour les périodes de gestation, de lactation et l'intervalle sevrage oestrus. Pour chacun de ces stades le logement est décrit sur la base d'une série de règles successives. Chacune d'entre elles est définie par un mode de fin (une durée ou un évènement physiologique) ainsi que les caractéristiques du logement (individuel, collectif, plein-air), du sol (caillebotis, paille, sol nus) et la température ambiante moyenne. Pour la gestation des informations complémentaires peuvent également être renseignées sur le comportement des animaux. Il est ainsi possible de prendre en compte des modes de logement différent au cours d'une même période. Par exemple le logement en début de gestation (attente saillie) peut être différent de celui en fin de gestation.


Profil animal (truie)

Profil animal

La "Profil animal" permet de saisir les principales caractéristiques de performances des animaux utilisés dans l'élevage. Le logiciel est livré avec les caractéristiques types de quelques lignées femelles, mais l'utilisateur peut définir un ou plusieurs types de truies correspondant aux lignées qu'il utilise.

La saisie de ces informations facilite grandement l'utilisation du modèle. Ces données sont en effet proposées comme données "standard" dans les différentes étapes de saisie, ce qui évite de les entrer à chaque fois. De plus certains paramètres du modèle de simulation sont ajustés à partir de ces informations. Il convient donc de les renseigner avec soin.

Les informations sont organisées en 3 rubriques principales qui concernent la truie, sa portée et son alimentation. Il est possible de renseigner automatiquement ces rubriques à partir des caractéristiques moyennes de l'élevage en utilisant les résultats de gestion technique de l'élevage (GTTT). Les informations ainsi saisies peuvent être représentées sous forme graphique. Ces données sont également utilisées pour le calibrage de certains paramètres du modèle de simulation.

Truie

Cette partie du tableau concerne l'évolution standard (ou recherchée) du poids vif des truies et de leur épaisseur de lard dorsal en fonction de leur âge et du numéro de portée. Le poids après mise bas peut être estimé à partir du poids avant mise-bas et des caractéristiques de la portée. Ces données sont utilisées pour ajuster la courbe d'évolution de l'objectif de poids après mise-bas en fonction de l'âge, pour le génotype considéré. L'équation ainsi obtenue peut être présentée sous forme graphique. Cette équation est ensuite utilisée lors du calcul factoriel des besoins pour la gestation. Pour les simulations ces données (poids, âge, épaisseur de lard dorsal) sont également utilisées comme paramètres de départ des calculs.

Portée

Cette partie du tableau concerne les performances moyennes de productivité numérique : nombres de porcelets nés totaux, nés vivants et sevrés et poids de naissance et de sevrage. Afin de pouvoir prendre en compte différents âges au sevrage, les poids des porcelets à 14, 21 et 28 j sont pris en compte.

Alimentation

Cette partie du tableau permet de renseigner la conduite alimentaire moyenne utilisée dans l'élevage en accord avec les performances renseignées aux rubriques Truies et Portée. Il s'agit d'une part des nivaux moyens de consommation par cycle pour la gestation et la lactation et d'autre part de la séquence alimentaire utilisée.

Graphiques

Cette rubrique permet d'afficher différents graphiques représentant l'évolution avec le numéro de portée des différents critères relatifs aux porcelets (poids, GMQ) ou à la truie (poids, épaisseur de lard dorsal). La courbe d'évolution, en fonction de l'âge, de l'objectif de poids vif après mise-bas est également présentée, ainsi que son équation.

Calibrage

Le modèle de simulation étant construit pour un génotype et un niveau de performance donné, il est nécessaire d'en ajuster certains paramètres afin qu'il corresponde mieux aux caractéristiques des animaux et de l'élevage considéré. C'est l'objectif de la phase de calibrage. Pour la gestation deux paramètres sont ainsi ajustés : la dépense énergétique d'entretien et l'évolution du potentiel de dépôt protéique en fonction du numéro de portée. De même pour la lactation deux paramètres ont également ajustés : la dépense énergétique d'entretien et la teneur minimale en protéines de la perte de poids.

Avant d'utiliser cette procédure il est nécessaire de compléter l'ensemble des données du profil. Ne pas oublier la séquence alimentaire (onglet alimentation) et le logement (onglet calibrage). Le calibrage se fait successivement pour la gestation et la lactation. Une représentation graphique en temps réel du poids vif et de l'épaisseur de lard dorsal simulés (traits plein) et réalisés (points) est affichée. Il est toujours possible de revenir aux paramètres initiaux à l'aide du bouton "reset". La procédure de calibrage prend environ 1 minute.

GITT

Cette rubrique permet de renseigner automatiquement les fiches "truie", "portée" et "alimentation", à partir des caractéristiques moyennes de l'élevage. Lorsque le bouton "calculer" est activé l'ensemble des rubriques de ces fiches sont remplacées par des valeurs estimées à partir des caractéristiques moyennes. Les valeurs précédentes sont alors écrasées. Pour que le profil soit complet il ne reste qu'à renseigner le choix de la séquence alimentaire dans l'onglet "alimentation".


Simulations (truie)

Simulations

Trois types de simulations peuvent être réalisés : simulation simple, comparaison de simulations et analyse de sensibilité.

La simulation simple est basée sur un profil truie, un plan de logement et des séquences alimentaires et plans de rationnement pour les portées différentes. Les simulations simples peuvent être sauvegardées sur le disque comme future références. La simulation est lancée en cliquant sur les boutons "Graphiques" ou "Rapport". L'objectif d'une simulation simple est de fournir une analyse détaillée des facteurs déterminant la croissance et aussi d'appréhender l'utilisation des nutriments pour des fonctions différentes.

La comparaison de simulations est effectuée en choisissant jusqu'au cinq simulations. Les résultats de ces simulations sont affichés graphiquement. Comparativement à une simulation simple, les informations analytiques sont réduites.

L'analyse de sensibilité permet de déterminer la sensibilité du modèle à un seul changement, lié à l'animal, l'aliment ou l'environnement. Ce type d'analyse permet de trouver des réponses aux questions comme "Que se passe-t-il si on modifie de 10% l'apport énergétique pendant la gestation ?", "Que se passe-t-il si on augmente le poids à la première saillie de 20% ?" ou "Que se passe-t-il si l'appétit des truie diminue de 5% pendant la lactation ?"


Simulation simple (truie)

Simulation simple

Cette partie du programme permet de simuler la réponse de la truie aux apports nutritionnels. Les simulations sont réalisées à l'aide d'un modèle de prédiction de l'utilisation des nutriments énergétiques et protéiques chez la truie. Ce modèle permet de d'estimer, au cours d'un ou plusieurs cycles de production, l'évolution de la composition corporelle (poids vif, épaisseur de lard) en fonction des apports alimentaires et des conditions de logement. Les descriptifs des simulations peuvent être enregistrés pour être utilisés ultérieurement ou pour réaliser des comparaisons entre plusieurs simulations ou des analyses de sensibilité.

Paramètres

Cette section permet de définir les paramètres de simulation liés à la truie, au mode de logement et à la conduite. Pour cela il suffit de sélectionner dans la liste un profil animal et un mode de logement et de renseigner la durée de lactation et de l'intervalle sevrage oestrus. Le dernier paramètre (Initialisation) concerne la procédure d'initialisation des simulations. Il s'agit de définir à quel rythme les paramètres de départ sur réinitialisés aux valeurs définie dans le profil animal :

  • A chaque stade : Le poids des truies et l'épaisseur de lard dorsal reprennent les valeurs stockées dans le profil truie au début de chaque stade (saillie, mise-bas). C'est l'option la plus sécuritaire.
  • A chaque cycle : Le poids des truies et l'épaisseur de lard dorsal reprennent les valeurs stockées dans le profil truie au début de chaque cycle (saillies).
  • Au début de la simulation : Le poids des truies et l'épaisseur de lard dorsal ne sont jamais réinitialisés pendant toute la durée de la simulation. Cette option doit être utilisée avec précaution, surtout si l'on simule un grand nombre de cycles successifs, dans la mesure où les risques de dérives des paramètres sont importants.

État initial et final

Cette zone permet de définir le numéro de portée et l'état physiologique des truies en début et en fin de simulation. En parallèle les phases prise en compte dans la simulation apparaissent dans le tableau "Alimentation" situé à droite de la zone de saisie de l'étal initial et final.

Alimentation

Une fois l'état initial et l'état final définis, il reste à renseigner les plans de rationnement et les séquences alimentaires utilisées. Des données doivent être saisies pour chacun des numéros de portée considérés dans la simulation. Pour cela sélectionnez à l'aide de la souris un numéro de portée. Les zones de saisie du plan de rationnement et de la séquence alimentaire apparaissent alors en dessous du tableau. Il ne reste plus qu'à choisir dans les listes proposées. Lorsque les informations concernant l'alimentation n'ont pas été correctement renseignées les données du numéro de portée correspondant apparaissent en rouge dans le tableau, sinon elles figurent en bleu.

Une fois que les données spécifiques à chaque période sont saisies il est possible de les imprimer et de lancer les simulations.


Simulation simple (truie): performances

Performances

Les résultats des simulations peuvent être affichés de façon dynamique ou par la période. Les options d'affichage (en mode dynamique) sont le gain (net) quotidien (g/j), le poids vif (net) (kg), la consommation d'aliment (g/j), l'indice de consommation (g/g), le dépôt (g/j) et le poids (kg) de protéines et de lipides (kg) corporels, l'épaisseur de lard dorsal (mm) et sa variation et la production laitière (kg/j). Les graphiques peuvent aussi être affichées par période (par cycle ou par stade). Ces statistiques peuvent être exprimées pour la durée de la période ou par jour.


Simulation simple (truie): Aliments

Aliments

Ce graphique présente les aliments utilisés pendant la simulation. Chaque aliment est codé par une couleur différente. Trois choix d'affichage sont possibles : la répartition globale, dynamique ou par période. Ainsi, la quantité de chaque matière première utilisée peut être affichée.


Simulation simple (truie): Protéines déposées et exportées

Protéines déposées et exportées

Ce graphique sert à identifier les facteurs susceptibles, au cours de la simulation, de limiter le dépôt de protéines ou l'exportation dans le lait. Il diffère des autres graphiques car son affichage ne peut être que dynamique en fonction de l'âge ou la durée. La liste à gauche du graphique énumère les facteurs qui limitent potentiellement le dépôt ou l'exportation de protéines. La liste est triée par ordre d'importance décroissante et est dépendante de chaque simulation (c.-à-d., l'ordre peut différer avec le changement d'animal ou de l'aliment). Les facteurs limitant réellement le dépôt ou l'exportation de protéines pendant au moins une journée sont marqués par un astérisque. La courbe noire, qui peut être cachée derrière d'autres courbes, représente le dépôt réel de protéine (en gestation) ou l'exportation dans le lait (en lactation).

Les facteurs limitants peuvent être sélectionnés par un clic gauche de souris, chacun génère un nouveau graphique présentant le dépôt de protéines permis par le facteur en question. Pendant la lactation, il est fréquent que l'apport de certains en acides aminés soit insuffisant pour couvrir l'exportation dans le lait. Les courbes concernant ces acides aminés seront dans alors en dessous de la courbe de production (en noir). La différence entre les deux courbes sera alors indicative de la mobilisation corporelle nécessaire pour maintenir la production laitière.


Simulation simple (truie): Acides aminés

Acides aminés

Ce graphique montre la répartition de l'utilisation des acides aminés essentiels (y compris l'arginine) et de l'azote. La cystine pouvant être synthétisée à partir de la méthionine et la tyrosine à partir de la phénylalanine, les données relatives à ces acides aminés sont donc indiquées pour la somme de ces acides aminés.

Les graphiques présentant la répartition des acides aminés distinguent huit composants : l'indigestible, l'endogène basal, l'entretien, l'oxydation minimale, le dépôt, le déséquilibre, le déficit, et l'excès. La fraction non digestible correspond à la fraction qui non digestible au niveau iléal et elle inclut aussi la fraction de l'endogène spécifique (c-à-d., 100 moins la digestibilité iléale normalisée). Les valeurs de digestibilité iléale standardisée pour les matières premières sont celles des tables récemment publiées par l'INRA-AFZ (Sauvant et al., 2004). Il en est de même pour la valeur de l'endogène basal qui varie en fonction de l'ingestion de matière sèche. L'entretien correspond à la perte d'acides aminés due au renouvellement des téguments (par exemple, les poils) et à la perte liée au turn-over minimal des acides aminés. Ces valeurs correspondent à celles publiées par Moughan (1999) et dépendent du poids vif à la puissance 0,75. On suppose qu'une fraction constante de l'apport en acides aminés au dessus du besoin de l'entretien sera oxydée (l'oxydation minimale). La valeur de cette fraction change selon les acides aminés et est calculée à partir du profil idéal d'acides aminés.

Le dépôt d'acides aminés (ou l'exportation dans le lait) dépend de la quantité de protéines et de son profil en acides aminés. Les trois autres composants (le déséquilibre, le déficit et l'excès) sont liés à une comparaison de l'apport en acides aminés, du dépôt réel de protéines et du dépôt de protéines dans le cas où l'apport de l'énergie limite de dépôt de protéine.

Le graphique de type "Apport et besoins" présente l'apport et les besoins sur la base de la digestibilité iléale standardisée ou apparente. L'apport total en acides aminés (mais pas les besoins) peut également être affiché. Les données peuvent être exprimés selon divers modes d'expression (g/j, relativement à lysine, g/MJ ED, g/MJ EM, g/MJ EN, g/kg ingéré, g/kg GMQ). Pour la gestation le besoin calculé correspond à l'apport nécessaire pour maximiser la rétention protéique. Pour la lactation il s'agit de l'apport nécessaire à la couverture des dépenses de production laitière.


Simulation simple (truie): Énergie

Énergie

L'utilisation de l'énergie peut être exprimée sur une base d'EB, ED, EM ou EN. Les composantes de l'énergie sont l'indigestible (fécal), l'énergie perdue sous forme de méthane, l'énergie urinaire, l'énergie pour l'entretien (y compris l'activité physique), la thermorégulation et l'extra-chaleur. Pendant la gestation, une partie de l'énergie est retenue par la truie (sous forme de protéines ou de lipides) et par sa portée. Pendant la lactation une partie de l'énergie est exportée dans le lait. Pendant la lactation, il est fréquent que l'apport d'énergie soit insuffisant pour couvrir l'exportation dans le lait, de l'énergie en provenant des réserves corporelles est alors mobilisée Selon le type de graphique choisie, l'énergie indigestible (ED), l'énergie du méthane et des urines (EM) ou l'extra-chaleur sont exclues du graphique.


Simulation simple (truie) : Minéraux

Minéraux

Ce graphique montre l'utilisation des minéraux pour des fonctions différentes. Le phosphore est actuellement le seul minéral pris en compte. Le besoin pour le phosphore est basé sur l'approche factorielle et est exprimé sur la base de digestibilité apparente fécale (Jondreville et Dourmad, 2005).

La fraction de phosphore indigestible dépend du type d'aliment, le traitement technologique (farine ou granulés) et l'utilisation de phytase microbienne. La phytase peut être inclue comme une matière première et doit alors être caractérisée par une valeur (d'équivalence) en phosphore digestible.

Il est possible que l'apport de phosphore soit insuffisant pour couvrir le besoin. Dans ce cas, le déficit sera affiché sur les graphiques, mais n'aura pas des conséquences sur les performances simulées.


Simulation simple (truie): Rétention et excrétion des minéraux

Rejets

Ce graphique indique la rétention et l'excrétion de N, P, Ca, K, Cu et Zn. Il est évident que cette information n'est pertinente que si la composition minérale des régimes est précise. Pour l'azote, la fraction excrétée est répartie entre les fractions urinaire et fécale. La rétention d'azote est calculée à partir de la rétention protéique et celle des autres minéraux à partir du poids vif (vide) (Dourmad et al., 2002, Jondrevillle et Dourmad, 2005).

P = 5,4199 · PV - 0,002857 · PV2
Ca = 8,64633 · PVV - 0,00180 · PVV2
K = 2,53338 · PVV - 0,00345 · PVV2
Cu = 2,8 + 1,05393 · PVV - 0,00251 · PVV2
Zn = 21,8 · PVV

Il est possible que l'apport minéral soit inférieur à la rétention calculée. Cependant dans la version actuelle d'InraPorc cela n'aura pas d'influence sur la croissance. Si un déficit survient, il sera indiqué simplement sur les graphiques.


Comparaison de simulations (truie)

Comparaison de simulations

Jusque cinq simulations peuvent être comparées simultanément. Pour cela il suffit de sélectionner les simulations à comparer dans la liste des simulations disponibles. Les résultats sont ensuite affichés sous forme graphique.


Analyse de sensibilité (truie)

Analyse de sensibilité

Une analyse de sensibilité consiste à tester l'influence de la modification d'une variable sur les résultats de la simulation. Par exemple il est possible de répondre à des questions du type :

  • Que se passe-t-il si on modifie de 10% l'apport énergétique pendant la gestation ?
  • Que se passe-t-il si on augmente le poids à la première saillie de 20% ?
  • Que se passe-t-il si l'appétit des truie diminue de 5% pendant la lactation ?

Pour cela il faut tout d'abord sélectionner la simulation sur laquelle on souhaite travailler, puis la variable d'entrée que l'on souhaite tester. Si la simulation concerne plusieurs cycles de production il est possible de réaliser l'analyse de sensibilité sur un ou plusieurs cycles. Par défaut tous les cycles sont pris en compte. Les valeurs moyennes prises par la variable sont alors affichées et l'on peut moduler le pourcentage de variation que l'on souhaite tester. Par exemple si le pourcentage de variation est fixé à 5% (valeur par défaut) la variable sélectionnée prendra successivement une valeur correspondant à 90%, 95%, 100%, 105% et 110% de la valeur définie dans la simulation. Il est alors possible d'afficher sur le même graphique les résultats obtenus dans ces différentes situations.


Comparaison de simulations (truie): Performances

Performances

Des résultats de plusieurs simulations peuvent être affichés dynamiquement ou globalement. Les options d'affichage incluent le gain (net) moyen quotidien (g/j), le poids vif (net) (kg), la consommation d'aliment (g/j), l'indice de consommation (g/g), le dépôt de protéines (g/j), le dépôt de lipides (g/j), le poids de protéines (kg), le poids de lipides (kg), l'épaisseur de lard dorsal et sa variation (mm) et la production du lait (kg/j).


Comparaison de simulations (truie): Aliments

Aliments

Ce graphique présente les aliments (et quantité et en coût) utilisés pendant la simulation. Chaque aliment est codé par une couleur différente. Ainsi, la quantité de chaque matière première utilisée peut être affichée.


Comparaison de simulations (truie): Acides aminés

Acides aminés

Ce graphique montre la répartition (moyenne) de l'utilisation des acides aminés essentiels et de l'azote pour différentes fonctions. Il peut aussi être utilisé pour montrer l'évolution au cours d'une simulation de l'apport ou du besoin d'un acide aminé. Les besoins peuvent être exprimés sur la base de digestibilité standardisée ou apparente. Ils peuvent être exprimés par jour, par kg d'aliment ou par kg du GMQ, relativement à la lysine ou par apport à l'énergie.


Comparaison de simulations (truie): Énergie

Énergie

Ce graphique montre la répartition (moyenne) de l'utilisation de l'énergie pour différentes fonctions. Elle peut être exprimée sur une base de l'EB, de l'ED, de l'EM ou de l'EN.


Comparaison de simulations (truie): Minéraux

Minéraux

Ce graphique montre la répartition (moyenne) de l'utilisation des minéraux pour différentes fonctions. Le phosphore est actuellement le seul minéral considéré. L'apport ou le besoin de phosphore digestible peut être affiché en fonction du temps ou en fonction du poids vif pour les différentes simulations qui sont comparées.


Comparaison de simulations (porcs croissance): Minéraux

Rejets

Ce graphique montre la rétention et l'excrétion (moyennes) de N, P, Ca, K, Cu et de Zn pour les différentes simulations qui sont comparées.


Calculs factoriel des besoins pour la gestation

Calculs factoriels des besoins pendant la gestation

Les besoins sont calculés selon la méthode factorielle, de façon à reconstituer un niveau optimal de réserves corporelles au moment de la mise-bas, niveau déterminé en fonction du poids vif et de l'épaisseur de lard dorsal. Pour cela différents types de dépenses sont pris en compte :

  • Les dépenses d'entretien : fonction du poids moyen de l'animal
  • Les dépenses de thermorégulation : fonction de la température ambiante et du mode de logement
  • Les dépenses liées à l'activité de l'animal : fonction du temps passé debout
  • Les dépenses liées au développement des contenus utérin : fonction du nombre et du poids des porcelets à la naissance
  • Les dépenses liées à la reconstitution des réserves corporelles

Profil animal

Cette zone permet de définir le type d'animal et le numéro de portée pour lesquels est effectué le calcul. Les valeurs proposées par défaut dans le reste du formulaire correspondent à celles définies pour cet animal dans la fiche Profil animal.

  • Saillie : Cette zone permet de saisir les caractéristiques de la truie à la saillie (âge, poids, épaisseur de lard). Les valeurs correspondantes au type d'animal et au numéro de portée sélectionnée sont proposées par défaut. D'autres valeurs peuvent être entrées.
  • Mise-bas : Cette zone permet de saisir les objectifs pour la truie et de sa portée à la mise-bas. Les valeurs correspondantes au type d'animal et au numéro de portée sélectionné sont proposées par défaut. Le poids vif après mise-bas est défini en fonction de l'âge à la mise-bas (saillie+114) et la courbe d'objectif d'évolution pondérale pour le Profil animal considéré. D'autres valeurs peuvent être entrées.

Logement

Cette zone permet de définir le type de logement et le comportement de l'animal. Par défaut le type de logement considéré est celui retenu dans la fiche Profil animal. Il est possible des modifier manuellement les paramètres du logement. Pour cela il suffit de choisir l'option "saisie manuelle" dans la zone de choix du type de logement.

  • Paramètres Loges : Trois caractéristiques du logement sont considérées : la conduite des animaux (en groupe, individuel, plein-air), le type de sol (paille, caillebotis, sol nu) et la température ambiante moyenne.
  • Comportement : Cette zone permet de prendre en compte l'activité de l'animal en fonction du temps passé debout. Une valeur moyenne de 240 mn (4 heures) est retenue par défaut.

Alimentation de référence

Le programme offre la possibilité de comparer les besoins ainsi calculés à un plan d'alimentation utilisé dans l'élevage, en ajustant éventuellement le niveau moyen d'alimentation apporté par ce plan. Par défaut le plan d'alimentation considéré est celui retenu dans la fiche Profil animal.

Résultats

Les besoins pour les principaux nutriments sont présentés dans la zone résultat. Pour en avoir une description plus détaillée il faut sélectionner les boutons "Rapport" ou "Graphiques".


Calculs factoriel des besoins pour la lactation

Calculs factoriels des besoins pendant la lactation

Les besoins journaliers en énergie, en acides aminés et en minéraux sont calculés selon la méthode factorielle, de façon à couvrir les dépenses de production laitière. Lorsque l'appétit des animaux est insuffisant pour couvrir les besoins énergétiques, le niveau réel de consommation est pris en compte pour fixer les besoins en acides aminés et en minéraux relativement à l'énergie où en pourcentage de l'aliment. La quantité d'énergie mobilisée à partir des réserves est également déterminée.

Profil animal

Cette zone permet de définir le type d'animal et le numéro de portée pour lesquels est effectué le calcul. Les valeurs proposées par défaut dans le reste du formulaire correspondent à celles définies pour cet animal dans la fiche Profil animal.

Lactation

Cette zone permet de saisir la durée de lactation et les objectifs de performances des porcelets pendant la lactation. Les valeurs correspondantes au type d'animal et au numéro de portée sélectionné sont proposées par défaut. D'autres valeurs peuvent être entrées.

Alimentation de référence

Cette zone permet de définir le niveau de moyen de consommation à volonté attendu pour la lactation. Lorsque, comme c'est souvent le cas, il est inférieur aux besoins des animaux, c'est ce niveau qui est utilisé pour calculer les besoins en acides aminés et en minéraux relativement à l'énergie où en pourcentage de l'aliment. Le programme offre également la possibilité de comparer les besoins ainsi calculés à un plan d'alimentation utilisé dans l'élevage, en ajustant éventuellement le niveau moyen d'alimentation apporté par ce plan. Par défaut le plan d'alimentation considéré et le niveau de consommation sont ceux retenus dans la fiche Profil animal.

Résultats

Les besoins pour les principaux nutriments sont présentés dans la zone résultat. Pour en avoir une description plus détaillée il faut sélectionner les onglets "Rapport" et "Graphiques".


Introduction (porc croissance)

Porc croissance

Les caractéristiques générales du module porc croissance ont été publiées dans les Journées de la Recherche Porcine (van Milgen et al., 2005) et dans une numéro spéciale sur la modélisation dans Animal Feed Science and Technology (van Milgen et al., 2008).

Pour réaliser une simulation, les aspects suivants devront être définis :

  • Séquence alimentaire
  • Plan de rationnement
  • Profil animal

Après les avoir défini, vous pouvez réaliser :

  • Simulation simple
  • Comparaison de simulations
  • Analyse de sensibilité


Séquence alimentaire (porc croissance)

Séquence alimentaire

Les aspects qualitatifs et quantitatifs de l'alimentation sont décrits indépendamment. Les aspects qualitatifs sont définis par un plan de séquence alimentaire, tandis que les aspects quantitatifs sont définis par un plan de rationnement. La séquence alimentaire détermine les aliments utilisés durant la simulation. Des séquences alimentaires sont proposées dans une liste, elles peuvent être sélectionnés, créées, supprimées, renommées ou imprimés en cliquant sur les boutons appropriés à droite de la liste. Un commentaire peut être ajouté à chaque séquence alimentaire.

Un ensemble de règles quantifient une séquence alimentaire. Chacune est définie par des objectifs qui conditionnent son arrêt et par l' (les) aliment(s) utilisé(s) durant son déroulement. La première règle débute avec la simulation et est appliquée jusqu'à ce que les conditions de son mode de fin soient réunies. Elle sera alors relayée par une deuxième règle selon le même principe et ainsi de suite. La dernière règle d'une séquence alimentaire est appliquée jusqu'à ce que les conditions de la fin de la simulation soient réunies (définies dans le profil du porc). Par défaut, il y a une règle pour chaque séquence alimentaire et des règles peuvent être ajoutées ou supprimées en utilisant les boutons situés sous la liste. Toutes les règles d'une séquence alimentaire sont énumérées et incluent les modes de fin de chaque règle ainsi que les aliments utilisés pendant la validité de chaque règle. Cette notion de règles est également exploitée dans la présentation des résultats des simulations. Ainsi, les performances moyennes associées à chaque règle d'une séquence alimentaire (comme les performances moyennes pendant les phases croissance et finition) peuvent être visualisées.

La mode de fin d'une règle est basée sur la durée, l'âge, le poids vif ou la quantité d'aliment distribuée cumulée (par exemple, l'aliment est changé lorsque le silo est vide). Après avoir déterminé le mode de fin, sa valeur numérique doit être saisie. L'aliment utilisé pendant une règle est choisi dans une liste. Quand le mode de fin d'une règle est défini par la durée, l'âge ou le poids vif. Deux aliments peuvent être utilisés simultanément. S'ils sont employés en mélange, le pourcentage du premier aliment sera indiqué relativement à l'aliment total offert. Une période de transition peut aussi être définie pendant laquelle un aliment est progressivement remplacé par une autre. Par exemple, on peut définir une séquence alimentaire pour les périodes de croissance et de finition dans lequel différents aliments sont utilisées. Et plutôt que de changer radicalement l'aliment, on peut programmer, par exemple à 60 kg, une transition progressive de l'aliment croissance (A) à l'aliment finition (B) sur une période de transition de sept jours. Pour définir une telle séquence alimentaire, trois règles sont nécessaires : la première indique l'utilisation de l'aliment A (jusqu'à 60 kg PV), la deuxième définit la période de transition et la troisième règle indique l'utilisation de l'aliment B jusqu'à la fin de la simulation. Dans ce cas, le mode de fin de la deuxième règle est déterminé par la durée (7 j) et les deux cases à cocher "2 aliments" et "transition" sont cochées. Pour assurer une transition complète, le pourcentage d'aliment A dans la ration devra passer progressivement de 100% au début à 0% à la fin de la règle.


Plan de rationnement (porc croissance)

Plan de rationnement

Pour les porcs en croissance, les aspects qualitatifs et quantitatifs de l'alimentation sont définis indépendamment. Les aspects qualitatifs sont définis par une séquence alimentaire, tandis que les aspects quantitatifs sont définis par un plan de rationnement. Le plan de rationnement permet de déterminer la quantité d'aliment offerte aux porcs. Des plans de rationnement sont proposés dans une liste, de nouveaux peuvent être créés, supprimés ou renommés en cliquant sur les boutons appropriés à droite de la liste. Un commentaire peut être ajouté pour chaque plan.

Les plans de rationnement sont comme les séquences alimentaires régis par un ensemble de règles. Chaque règle est définie par des modes de fin et par la quantité d'aliment (ou d'énergie) distribuée durant la durée d'application de la règle. La première règle commence au début de la simulation et est appliquée jusqu'à ce que les conditions de son mode de fin soient réunies. Elle sera alors relayée par une deuxième règle selon le même principe et ainsi de suite. La dernière règle dans un plan de rationnement est appliquée jusqu'à ce que les conditions de la fin de la simulation soient réunies. Par défaut, il y a une règle par plan de rationnement alimentaire et des règles peuvent être ajoutées ou supprimées en utilisant les boutons situés au-dessous de la liste. Toutes les règles d'un plan de rationnement sont énumérées et incluent les modes de fin de chaque règle et les quantités d'aliments utilisés pendant l'application de chaque règle.

Les conditions requises pour la fin d'une règle sont basées sur la durée, l'âge, le poids vif ou la quantité d'aliment distribuée (cumulée). Après avoir déterminé le mode de fin, la valeur numérique doit être saisie.

En raison de gaspillage d'aliment, la quantité d'aliment ingéré peut être différente de la quantité distribué. Bien que le gaspillage soit difficile à mesurer, la plupart des rapports suggèrent que le gaspillage est au moins 2 à 3% de l'aliment distribué. Parce que le gaspillage peut varier en fonction du niveau alimentaire (le gaspillage sera probablement plus faible lorsqu'une restriction alimentaire est appliquée), vous pouvez spécifier le gaspillage d'aliment pour chaque règle. Des critères tels que l'indice de consommation sont exprimés par rapport à l'aliment distribué, et pas à l'aliment ingéré.

L'aliment peut être offert ad libitum ou un pourcentage d'ad libitum, à niveau constant, ou en fonction du poids vif ou de l'âge. Quand l'aliment est offert ad libitum, aucune information supplémentaire n'est exigée (la capacité d'ingestion est considérée comme une caractéristique de l'animal, définie dans le profil animal). Les autres modes d'expression définissent les conditions de restriction, ils sont exprimés relativement à la quantité d'aliment (frais ou MS) ou sur la base de l'énergie (ED, EM ou EN).

Quand la distribution d'aliment est définie en fonction du poids vif (PV) des fonctions linéaire (a + b · PV), asymptotique (a · (1 - exp(-b · PV)) ou puissance (a · PVb) peuvent être choisies. Dans la mesure où il peut être difficile de trouver intuitivement les valeurs pour a et b, la quantité d'aliment (ou d'énergie) distribuée à 50 et 100 kg de poids vif (QI50 et QI100) peut être indiquée et les valeurs de a et b seront alors calculées selon l'équation appropriée. La distribution alimentaire peut aussi être exprimée selon une fonction linéaire du temps avec des ajustements journaliers ou hebdomadaires.

Il est possible de tester le plan de rationnement en cours de construction dans une simulation. Lorsque vous sélectionnez une simulation de référence dans le panneau de droite, des informations concernant le profil animal et la séquence alimentaire (de la simulation de référence) seront combinés avec le plan de rationnement en cours de construction. De cette façon, vous pouvez vous assurer que le plan de rationnement fonctionne comme prévu.


Profil animal (porc croissance)

Profil animal

Le profil animal (ou le potentiel phénotypique de l'animal) est défini comme les performances de croissance obtenues dans des conditions idéales lorsque ni l'alimentation ni l'environnement (climatique) ne les limitent. Chaque profil porte un nom unique. Des profils peuvent être créés, supprimés ou renommés grâce aux boutons à droite de la liste. La définition d'un profil de croissance comporte deux étapes indiquées par les onglets : Conditions d'élevage et Consommation ad libitum et croissance. Parce qu'il peut être difficile de trouver les paramètres du modèle "manuellement", une procédure de calibration est disponible où les paramètres du modèle sont estimés statistiquement en utilisant des observations sur l'aliment distribué et la croissance.

Les principes généraux du module porc croissance ont été publiés dans un texte présenté aux Journées de la Recherche Porcine (van Milgen et al., 2005 ; en français) et dans un numéro spécial sur la modélisation dans la revue Animal Feed Science and Technology (van Milgen et al., 2008).


Profil animal (porc croissance) : Conditions d'élevage

Conditions d'élevage

Les conditions d'élevage concernent seulement l'état initial et final et le sexe de l'animal. Dans le cadre "état initial", l'âge, le poids vif, les poids de protéines et de lipides corporels sont définis. Dans le modèle, le poids vif est calculé par une fonction allométrique des poids de protéines et de lipides. Par conséquent, pour un poids vif initial donné, soit la part protéique, soit la part lipidique doit être définie, l'autre poids étant calculé. Par défaut, le poids initial de protéines est calculé en fonction des protéines dans le poids vif vide (16%) et la relation entre poids vif vide et poids vif. Le poids de protéines est modifiable dans des limites raisonnables.

Les conditions retenues pour la fin de la simulation sont définies dans le cadre "État final". La simulation peut être définie pour un nombre de jours fixé (à partir de l'âge initial) ou jusqu'à un certain poids vif. En outre, le rendement de carcasse (le poids de carcasse en pourcentage du poids vif) est exigé comme donnée d'entrée du modèle. Par défaut, la carcasse comprend la tête (y compris la langue), les pieds et la queue. Comme la définition de la carcasse peut changer selon les pays, la définition de la carcasse peut être modifiée dans le menu de configuration d'InraPorc.


Profil animal (porc croissance): Consommation et performances ad libitum

Consommation ad libitum et croissance

Dans cet onglet les paramètres du profil concernant la consommation à volonté et la croissance correspondante sont indiquées. Le fait que ces informations soient nécessaire montre bien que le modèle ne prédit pas les performances dans l'absolu. Basé sur les informations fournies ici, vous pouvez analyser (dans une simulation simple) l'utilisation des nutriments par l'animal, ou de prédire les conséquences d'un changement de la stratégie alimentaire.

Cet onglet comporte 3 zones différentes :

  • Paramètres du modèle: paramètres qui décrivent la consommation à volonté et la croissance
  • Simulation de référence: la séquence alimentaire et le plan de rationnement qui sont utilisés pour tester le profil animal
  • Résultats de la simulation: des résultats graphiques et numériques des simulations

Les paramètres définis dans cet onglet peuvent être saisis manuellement ou ils peuvent être obtenus par une procédure de calibration. Avec cette procédure, vous devez fournir des données (observées) pour la consommation et la croissance de l'animal et les paramètres du modèle seront obtenus par une estimation statistique.

Paramètres du modèle

Consommation ad libitum

La capacité d'ingestion est considérée comme une caractéristique de l'animal. C'est la raison pour laquelle elle est définie dans le profil animal et pas dans le plan de rationnement. Dans un plan de rationnement, c'est la conduite d'élevage appliquée par l'éleveur qui est identifiée (par exemple, l'aliment est offert à volonté). Nous supposons que la capacité d'ingestion dépend du poids vif de l'animal. Néanmoins, on sait que le poids vif n'est pas le seul facteur déterminant la prise alimentaire. Les conditions environnementales, le statut sanitaire, la densité (ou la place à l'auge) peuvent également influencer la consommation à volonté. D'ailleurs, les mécanismes de contrôle de l'ingestion ne sont pas complètement connus. Lorsque la capacité digestive limite la prise alimentaire, celle-ci peut être régulée sur la base de la quantité de matière sèche (ou de l'encombrement). Si ce n'est pas le cas, un contrôle de l'ingestion par la quantité d'énergie ingérée semble plus probable. Dans InraPorc, le choix du contrôle de l'ingestion ad libitum est laissé à l'utilisateur (c.-à-d., sur frais, MS, ED, EM, EN). La façon d'exprimer la consommation ad libitum a des conséquences sur la manière dont le modèle prédit la réponse à un régime riche en énergie. Par exemple, si la consommation ad libitum est exprimée sur la base de la matière sèche, un régime riche en énergie améliorera des performances. Par contre, si la consommation ad libitum est exprimée en fonction de l'EN, un régime hypercalorique réduira l'ingestion de matière sèche (pour maintenir la même ingestion en EN) sans affecter les performances.

Quatre types d'équations sont disponibles pour exprimer la consommation ad libitum : une fonction linéaire (ingéré = a + b · PV), une fonction puissance (ingéré = a · PVb), une fonction asymptotique (ingéré = a · (1 - exp (-b · PV))), ainsi qu'une fonction Gamma par rapport à l'entretien énergétique. La fonction Gamma suppose que la consommation ad libitum peut (ou doit) être exprimée relative à la dépense énergétique pour l'entretien. Lorsque le poids des animaux s'approche au poids à la maturité, la consommation ad libitum doit s'approcher à la dépense énergétique pour l'entretien et la croissance s'arrête en conséquence. Par ce que la dépense énergétique pour l'entretien est exprimée relativement au PV0.60, la fonction Gamma peut être décrite aussi comme une fonction du PV (c.-à-d., ingéré = (a · (b · PV · exp(-b · PV)) + 1) · c · PV0.60). La valeur de "c" dépend de l'unité d'expression de la consommation ad libitum (par exemple, c = 0.75 MJ/PV0.60/j quand la consommation est exprimée sur la base d'EN). Par rapport aux autres fonctions, la fonction Gamma est très flexible et permet de paramétrer une réduction de la consommation avec l'augmentation du poids de l'animal. Dans la mesure où il pourrait être difficile pour des non-initiés de fournir des estimations de a et b, le logiciel prévoit de les calculer à partir des valeurs de consommation à 50 et 100 kg de poids vif (QI50 et QI100).

Potentiel de croissance

Le critère PD moyen (g/j) indique le dépôt moyen de protéines réalisé pendant la simulation dans l'hypothèse où l'apport en acides aminés n'est pas limitant. Le PD moyen est défini en fonction du temps ; par conséquent, il correspond à la moyenne du PD simulé quand la durée de la simulation est fixe. Quand la simulation dure jusqu'à l'obtention d'un poids vif donné, la valeur moyenne du dépôt protéique simulé peut légèrement différer du paramètre PD moyen. La masse protéique dans des conditions ad libitum est décrite par la fonction de Gompertz, fonction sigmoïdale du temps. Pour décrire PD, la première dérivée de la fonction de Gompertz est utilisée.

Le paramètre Précocité (/j) indique comment PD change en fonction de l'âge et permet de différencier les animaux à maturation précoce ou tardive. Une valeur élevée désigne un porc à maturation précoce (qui dépose davantage des protéines en début de croissance) tandis qu'une valeur faible désigne un porc dont la maturation est tardive. Le PD moyen de la simulation reste relativement constant lorsque l'on modifie la précocité.

Dans le modèle, le besoin en énergie pour l'entretien est calculé en fonction du poids vif et de la consommation alimentaire. Le paramètre Entretien permet de changer les besoins en énergie pour l'entretien relativement à la valeur par défaut. La modification de ce paramètre changera le LD, l'épaisseur de gras dorsal et le taux de muscle des pièces (TMP) mais pas (ou peu) le PD.

Le paramètre PV PDmax indique le poids à partir duquel l'animal est capable de consommer suffisament pour que le PD puisse atteindre un plateau (nommé "PDmax"). Ce paramètre détermine la façon que les porcs répondent à une restriction alimentaire (par exemple, appliquée dans la phase de finition). A sa valeur par défaut (70 kg), une restriction alimentaire modérée appliquée à partir de 80 kg réduira le LD sans avoir un effet sur le PD. Par contre, avec une valeur élevée du PV PDmax (par exemple, 300 kg), une restriction alimentaire à partir de 80 kg réduira LD et PD. En l'absence d'information fiable, il est préférable d'utiliser la valeur recommandée par défaut, soit 70 kg. Pour mieux comprendre les forces motrices du modèle, veuillez cliquez sur le bouton "Courbe de réponse".

Simulation de référence

Dans ces deux listes, la séquence alimentaire et le plan de rationnement peuvent être indiqués qui sont utilisées dans une simulation. Cette simulation vous permettra d'évaluer vos choix de paramètres du profil animal. Dans des calculs internes, la consommation à volonté et la croissance correspondante sont souvent utilisés comme une situation de référence. En conséquence, il est important que les paramètres qui décrivent la consommation ad libitum soient raisonnablement réaliste. Nous vous conseillerons fortement de choisir un plan de rationnement où les animaux ont accès à l'aliment à volonté pendant une partie considérable d'une simulation.

Avec le bouton "Calibration", vous pouvez accéder au module qui permettra d'utiliser des données observées par l'utilisateur à fin d'obtenir les paramètres du profil animal par une estimation statistique.

Résultats de simulation

Les résultats sont affichés numériquement et graphiquement pour deux simulations qui diffèrent en quantité d'aliment distribuée. Le graph et les données numériques affichées en noir concernent la consommation ad libitum (sans gaspillage) alors que le graph et données affichées en rouges utilisent le plan de rationnement de référence (qui peut inclure du gaspillage). Les deux simulations utilisent des paramètres du profil animal en cours de création et la séquence alimentaire de la simulation de référence. Les résultats numériques sont affichés comme des valeurs moyennes (pour le GMQ, aliment distribué, IC, PD et LD) ou comme valeurs finales (épaisseur de lard dorsal et TMP). L'épaisseur de lard dorsal et le TMP sont calculés à partir des masses de protéines et de lipides. Comme il s'agit de résultats indirects, il conviendra de les interpréter avec précaution quand ils sont utilisés pour paramétrer le modèle. Ils servent davantage à fournir une approximation qu'une référence absolue. Plusieurs raisons pourraient être à l'origine d'une mauvaise prédiction de l'épaisseur de lard dorsal et/ou le TMP :

  • Les paramètres du modèle pour la consommation ad libitum reflètent la consommation réelle, et pas la distribution d'aliment. Si vous avez sous-estimé le gaspillage d'aliment, la consommation ad libitum sera surestimée. Cela a pour conséquence que l'état d'engraissement de la carcasse sera surestimé. Plutôt que d'adapter le paramètre Entretien afin de mieux prédire l'état d'engraissement de la carcasse, il faut mieux ajuster le gaspillage d'aliment indiqué dans le plan de rationnement.
  • Les équations pour prédire l'épaisseur de lard dorsal et le TMP ne peuvent pas être adaptées pour votre situation. Vous pouvez changer les équations de prédiction pour ces critères dans le menu de configuration d'InraPorc.
  • Finalement, il est possible que le paramètre Entretien doit être ajusté (par exemple, par ce que les animaux sont plus actifs qu'anticipés).


Calibration d'un profil animal (porc croissance)

Calibration d'un profil animal

Il est possible d'estimer, par analyse statistique, les paramètres qui décrivent la consommation ad libitum et la croissance à partir des informations fournies par l'utilisateur. La procédure pour ce faire consiste en deux étapes :

  • Fourniture des données pour la calibration
  • Estimation des paramètres du modèle par calibration

Fourniture des données pour la calibration

Chaque ligne de données doit comporter l'âge et jusqu'à quatre autres critères (aliment distribué cumulé, poids vif, épaisseur de lard dorsal et teneur en viande maigre). Les données pour l'aliment distribué cumulé et le poids vif doivent être fournies afin d'estimer les paramètres du modèle alors que les données pour l'épaisseur de lard dorsal et la viande maigre sont facultatives. Veuillez considérer les aspects suivants lors de la fourniture de données :

  • Les données doivent être fournies dans l'ordre chronologique
  • Il faut un minimum de trois lignes de données
  • L'aliment distribué cumulé de la première ligne doit être égal à zéro

Les données peuvent être fournies par saisie manuelle ou par l'importation de données depuis un fichier CSV. Lorsque vous importez des données à partir d'un fichier CSV, assurez-vous que ce fichier ne contient que les données requises et pas de calculs intermédiaires utilisés dans le tableur. Veuillez consulter cet exemple lorsque vous voulez utiliser des données observées pour la création d'un profil animal.

Estimation des paramètres du modèle par calibration

La procédure de calibration consiste à trouver les paramètres du modèle qui décrivent le mieux vos données observées. Cela se fait par une procédure statistique en utilisant les algorithmes de TPMath. En "mode standard", InraPorc estime les paramètres du modèle PV Init (et donc la masse de protéines initiale) QI50, QI100, PD moyen et Précocité en utilisant les données sur l'aliment distribué cumulé et le poids vif. Par défaut, l'épaisseur de lard dorsal et le TMP ne sont pas inclus dans la procédure d'estimation. La procédure d'estimation passera par plusieurs étapes afin d'estimer ces paramètres.

Le "mode expert" est disponible pour des utilisateurs avancés qui (pensent qu'ils) savent ce qu'ils font. En "mode expert", vous avez accès à différentes options statistiques :

  • Sélectionner une ou plusieurs variables dépendantes
  • Changer les poids statistiques des variables dépendantes
  • Sélectionner les paramètres à estimer
  • Sélectionner l'algorithme d'optimisation
  • Ne pas considérer l'apport en acides aminés comme un facteur potentiellement limitant pour la croissance. La procédure de calibration peut avoir des difficultés à trouver les paramètres lorsque les acides aminés limitent les performances. Si vous décochez la case, la procédure de calibration ignorera tout simplement l'apport en acides aminés. Il est alors important d'avoir conscience que, selon InraPorc, les performances observées ne pouraient pas être réalisées avec ce type de régime.

En "mode expert", vous pouvez inclure l'épaisseur de lard dorsal et le TMP dans la procédure d'estimation. Plusieurs raisons pourraient être à l'origine d'une mauvaise prédiction de l'épaisseur de lard dorsal et/ou du TMP :

  • Les paramètres du modèle pour la consommation ad libitum reflètent la consommation réelle, et pas la distribution. Si vous avez sous-estimé le gaspillage d'aliment, la consommation ad libitum sera surestimée. Cela a pour conséquence que l'état d'engraissement de la carcasse sera surestimé. Plutôt que d'adapter la valeur de correction de l'entretien afin de mieux prédire l'état d'engraissement de la carcasse, il est préférable d'ajuster le paramètre de gaspillage d'aliment dans le plan de rationnement.
  • Les équations pour prédire l'épaisseur de lard dorsal et le TMP peuvent ne pas être adaptées pour votre situation. Vous pouvez changer les équations de prédiction pour ces critères dans le menu de configuration d'InraPorc.
  • Enfin, il est possible que le paramètre Entretien doive être ajusté (par exemple, parce que les animaux sont plus actifs que ce que vous avez anticipé).


Profil animal (porc croissance) : Loi de réponse à l'énergie

Loi de réponse à l'énergie

Cette fenêtre décrit la répartition de l'utilisation de l'énergie entre PD et LD au cours d'une simulation. Les graphiques (en 2D ou 3D) présentent PD et LD comme des fonctions de la consommation d'énergie au-dessus de l'entretien à un temps donné.

Pour le graphique en 2D, l'apport en énergie nette (EN) est représenté sur l'abscisse inférieure et exprimé en fonction du besoin pour l'entretien (1 = entretien) ; l'abscisse supérieure indique l'équivalent en quantité d'aliment. La relation entre les abscisses inférieure et supérieure n'est pas constante car le niveau d'entretien dépend du poids vif et de la consommation. Le PD (en rouge) est donné sur l'ordonnée à gauche et le LD (en bleu) sur celle de droite. Les points pleins sur ces courbes indiquent les valeurs de PD et de LD pour un porc nourri à volonté. La cinétique de répartition de l'énergie pendant la croissance peut être simulée par déplacement du curseur dans la règle au-dessous du graphique. L'incrémentation de cette règle correspond à 1 jour et peut être obtenue avec la souris ou le clavier ("flèche droite" = jour +1, "flèche gauche" = jour -1, "bas de page" = +7 jours, "haut de page" = -7 jours).

Le PD (et LD) marginal est défini comme la variation du PD résultant d'une modification de l'énergie ingérée (c.-à-d., la tangente du PD lors d'une consommation ad libitum, représentée par un segment noir sur le graphique). Dans InraPorc, on suppose que le PD marginal diminue linéairement lorsque le poids vif augmente. Quand le PD marginal devient nul, la consommation à volonté est suffisante pour atteindre PDmax et le PD n'est plus affecté par une légère modification de l'apport énergétique. On suppose que le PD marginal à 20 kg de poids vif est de 8,4 g PD/MJ EN et cette donnée est codée "en dur" dans le logiciel. Le paramètre PV PDmax indique le poids vif auquel le PD marginal devient nul. Lorsque le poids vif est supérieur à PV PDmax, le PD est limité par PDmax et pour des poids inférieurs à PV PDmax, le PD est limité par l'apport énergétique. Comme il est très difficile dans la pratique de déterminer la valeur du PV PDmax, il peut être estimé en étudiant l'effet d'une restriction alimentaire (relativement à la consommation à volonté) sur la performance.

Le graphique en 3D permet de suivre la trajectoire de croissance sur la surface de réponse. Les courbes de réponse pour la consommation à volonté (en noir) ainsi que pour le plan de rationnement sélectionné (en rouge) sont affichées. Si vous modifiez les paramètres PD moyen ou Précocité, les courbes et la surface de réponse seront modifiées. Alors que si vous modifiez PV PDmax, seule la surface sera modifiée. Les différents curseurs autour du graphique 3D permettent d'en modifier la vue (perpesctive, zoom, rotation verticale ou horizontale).

La théorie derrière ces courbes de réponse

Un des premiers modèles nutritionnels décrivant la croissance des porcs (Whittemore et Fawcett, 1976) supposait l'existence d'une relation de type linéaire-plateau entre PD et l'apport énergétique. Le plateau indique la limite supérieure de PD (PDmax), déterminée par des facteurs génétiques et environnementaux. Pour une consommation inférieure à celle nécessaire pour atteindre PDmax, le PD diminue alors linéairement avec l'ingestion de l'énergie. Dans InraPorc, une approche légèrement différente est employée, le PD varie en fonction de la consommation d'énergie selon une fonction de type curvilinéaire-plateau. Elle est basée sur l'hypothèse que la part de l'énergie pour le PD (appelé "X" ; cf. van Milgen et al., 2000) est une fonction linéaire de l'apport en énergie. Une réduction de l'énergie ingérée augmentera la fraction de l'énergie disponible pour le PD au détriment celle du LD (1 - X). Par conséquent, une restriction énergétique affecte à la fois le PD et le LD, avec une diminution plus rapide du LD relativement au PD. Le graphique illustre la loi de réponse de PD et de LD à l'énergie ingérée.

L'approche utilisée dans InraPorc diffère légèrement de celle que nous avions développé préalablement (van Milgen et Noblet, 1999 ; van Milgen et al., 2000). Dans InraPorc, la répartition de l'énergie est basée sur l'énergie nette (EN) et non sur l'énergie métabolisable (EM). Dans l'approche de van Milgen et al. (2000), le PDmax et l'énergie nécessaire pour l'atteindre (appelé "F") servaient de points de référence. Cette approche pose problème car les porcs en croissance et/ou finition sont parfois incapables de consommer cette quantité d'énergie. Dans InraPorc, la consommation à volonté et le PD correspondant sont utilisés comme points de référence. Il est maintenant admis que le PD dans les conditions d'une alimentation à volonté (ce qui est différent du PDmax) varie selon la fonction de Gompertz. En outre, la réponse de PD à une variation de l'apport énergétique est maintenant modélisée par le PD marginal (pour une consommation à volonté) plutôt que par l'apport énergétique requis pour atteindre le PDmax.

Sur le graphique en 2D, des valeurs numériques pour X (sur une base EN), PDmax et F sont données. Des statistiques concernant d'autres théories de la répartition de l'énergie (par exemple, LD/PD minimal, rapport minimal entre les masses des lipides et des protéines) peuvent être obtenues en effectuant une simulation simple (dans l'onglet "Énergie", Type de graphique: "Répartition de l'énergie retenue").


Parameterization of an animal profile for growing pigs (example)

Paramétrage d'un profil pour le porc en croissance (un exemple)

Paramétrer un profil animal est un élément essentiel d'InraPorc. Un profil animal décrit le potentiel phénotypique de la croissance et de la consommation du porc (c.-à-d., le potentiel d'un génotype dans son environnement d'élevage). En conséquence, des paramètres spécifiques doivent être trouvés pour chaque environnement d'élevage.

InraPorc utilise la forme de la courbe de la consommation et de la courbe de croissance pour déterminer les besoins nutritionnels. En conséquence, avoir uniquement des informations sur la consommation moyenne et la croissance moyenne ne permet pas de décrire la cinétique de ces deux courbes. Cependant, si des données sur la consommation et la croissance sont disponibles pendant deux périodes (ou plus), les courbes de cinétique de la consommation et de la croissance peuvent être construites. Dans cette exemple, nous décrirons comment obtenir les paramètres du modèle basés sur la consommation et la croissance observées pendant deux périodes. Le but de l'exercice est de trouver des paramètres du modèle qui correspondent (approximativement) à la situation suivante :

 | Moyen | Croissance | Finition
Consommation d'aliment (kg/j) | 2,20 | 1,75 | 2,60
Gain moyen quotidien (g/j) | 775 | 700 | 850
Indice de consommation | 2,84 | 2,50 | 3,06

La procédure pour trouver des paramètres qui correspondent à cette situation peut être réalisée par la procédure de calibration. Pour illustrer cette procédure, nous recommandons de créer un nouveau profil animal. Ceci peut être fait en cliquant sur le bouton vert "+", sans copier les valeurs du profil courant.

Conditions d'élevage

Pour notre exercice, nous recommandons que vous utilisiez les valeurs par défaut pour les paramètres Age initial (60 jours) et Poids vif initial (25 kg). Le paramètre Poids vif final peut être mis à 120 kg.

Consommation ad libitum et croissance

Supposons que la régulation de la consommation soit déterminée par l'énergie nette. Pour notre exercice, nous choisirons la fonction Gamma (de l'entretien). Avec cette équation, la consommation sera exprimée par rapport au besoin énergétique pour l'entretien. Avec l'augmentation du poids, la consommation s'approchera de la dépense énergétique pour l'entretien et la croissance cessera progressivement. Les autres fonctions de consommation n'ont pas nécessairement cette propriété. Le paramètre a de la fonction Gamma est un paramètre d'échelle et b est un paramètre de forme. Les valeurs actuelles sont des valeurs par défaut.

Afin d'utiliser la procédure de calibration, vous devrez sélectionner une séquence alimentaire et un plan de rationnement. L'apport en nutriments dans la séquence alimentaire ne doit pas être limitant pour la performance (sinon, l'animal ne serait pas en mesure d'exprimer son potentiel de croissance phénotypique). Aux fins de cet exemple, vous pouvez sélectionner la séquence alimentaire "Bi-phase standard". Avec cette séquence alimentaire, deux aliments seront utilisés et le changement d'aliment se fera à 65 kg de poids vif de l'animal.

Vous devez également choisir un plan de rationnement. Le plan de rationnement doit contenir une longue période de distribution ad libitum afin que les paramètres de consommation ad libitum puissent être estimés avec une précision raisonnable. Dans l'exemple ci-dessus, nous ne disposons que de 2 périodes, ce qui signifie que nous ne disposons que de 2 données pour la quantité d'aliment distribué. Comme la courbe de la consommation ad libitum a 2 paramètres, il est évident que la calibration n'aura de sens que si les animaux ont reçu l'aliment ad libitum tout au long de la période d'essai. Dans le plan de rationnement "Ad libitum", il n'y pas de gaspillage d'aliment. Bien que ce ne soit pas réaliste, nous l'utiliserons en tant que telle pour cet exemple.

Calibration

Données observées

Après avoir cliqué sur le bouton "Calibration", vous devez saisir les données observées dans les cellules appropriées. Les données doivent être fournies dans l'ordre chronologique. L'aliment distribué doit être saisi comme l'aliment distribué cumulé et nous avons donc à faire quelques calculs avant de pouvoir saisir les données. Les données ci-après correspondent à ceux du tableau ci-dessus (l'âge est arrondi aux valeurs entières) :

Ligne | Age | Aliment distribué cumulé (kg) | Poids vif (kg) | Epaisseur de lard dorsal (mm) | TMP (%)
1 | 60 | 0,0 | 25,0 |  |
2 | 117 | 99,7 | 64,9 |  |
3 | 182 | 268,7 | 120,1 |  |

Calibration

Après avoir saisi les données (et en cliquant sur "OK"), la fenêtre de calibration s'ouvrira. Il est plus facile de rester en "mode standard" et de cliquer simplement sur le bouton "Calibration". InraPorc essayera ensuite d'estimer les paramètres qui prédisent au mieux les données observées. Après la calibration, vous pouvez cliquer sur "OK" et enregistrer le profil animal pour un usage ultérieur.


Simulation (porc croissance)

Simulations

Trois types de simulations peuvent être réalisés : simulation simple, comparaison de simulations et analyse de sensibilité

La simulation simple est basée sur un profil de croissance, une séquence alimentaire et un plan de rationnement. Les simulations simples peuvent être sauvegardées sur le disque comme future références. La simulation est lancée en cliquant sur les boutons "Graphiques", "Rapport" ou "Excel". L'objectif d'une simulation simple est de fournir une analyse détaillée des facteurs déterminant la croissance et aussi d'appréhender l'utilisation des nutriments pour des fonctions différentes.

La comparaison de simulations est effectuée en choisissant des combinaisons de profils de porc, de séquences alimentaires et de plans de rationnement. Par exemple, différents aliments peuvent être évalués en sélectionnant un seul profil de porc, différentes séquences alimentaires et un seul plan de rationnement. Comparativement à une simulation simple, les informations analytiques sont réduites.

L'analyse de sensibilité permet de déterminer la sensibilité du modèle à un seul changement, lié à l'animal ou à l'aliment. Ce type d'analyse permet par exemple de prévoir la croissance d'un animal dans le cas d'une réduction du niveau alimentaire de 5% ou de connaître l'amélioration des performances dans le cas d'un apport supplémentaire de 10% de lysine.


Simulation simple (porc croissance)

Simulation simple

Le but d'une simulation simple est de fournir une analyse détaillée des facteurs déterminant la croissance et aussi d'appréhender l'utilisation des nutriments pour les différentes fonctions. La simulation simple est basée sur un profil de croissance, une séquence alimentaire et un plan de rationnement. Les conditions initiales et finales retenues par défaut sont celles définies dans le profil retenu, toutefois elles peuvent être modifiées par l'utilisateur. Les résultats de simulation simple peuvent être présentés sous forme de graphiques, de rapport ou exportées vers un fichier Excel pour une utilisation ultérieure.

Graphiques

Les graphiques peuvent être présentés sous différents types en choisissant l'onglet approprié (c.-à-d., performances, aliments, facteurs limitant le dépôt de protéine, l'utilisation des acides aminés, l'utilisation de l'énergie, l'utilisation des minéraux et les rejets). Les graphiques sont définis par trois critères : le type de graphe, le variable de l'ordonné (Y) et le variable de l'abscisse (X). Selon l'onglet choisi, les listes proposées seront adaptées au type de graphique. Pour la plupart des onglets plusieurs types de graphique sont disponibles :

  • répartition globale : affiche le résultat moyen pour toute la simulation
  • affichage dynamique : présente les résultats en fonction du temps, de l'âge et du poids vif
  • par période : donne le résultat pour chaque période (pour la séquence alimentaire, le plan de rationnement, la semaine, ou globalement).

Des graphiques supplémentaires peuvent être disponibles selon les critères choisis (par exemple, l'utilisation des acides aminés, ou l'utilisation de l'énergie). Les variables dépendantes peuvent être exprimées sous diverses unités (par exemple, g/j, g/kg de gain, g/kg aliment). Les graphiques peuvent être imprimés par simple clic droit sur le graphe.

Rapport

Le rapport donne un bref sommaire des résultats.

Excel

Les résultats finaux d'une simulation peuvent être exportés vers une feuille de calcul Excel. InraPorc écrit les données dans un onglet spécifique d'une feuille de calcul (son emplacement peut être défini dans la fenêtre de configuration). Cela permet aux utilisateurs de construire des modules supplémentaires dans d'autres feuilles (par exemple, une analyse économique) où InraPorc fournira les données.


Simulation simple (porc croissance): performances

Performance

Les résultats des simulations peuvent être affichés dynamiquement ou par la période. Les options d'affichage concernent différents aspects du poids vif, temps, aliment distribué, efficacité alimentaire, les masses de protéines et de lipides et la qualité de carcasse. Des graphiques peuvent aussi être affichés par période (par exemple, pour chaque règle d'une séquence alimentaire ou plan de rationnement).


Simulation simple (porc croissance): Aliments

Aliments

Ce graphique présente les aliments utilisés (en quantité et en coût) pendant la simulation. Chaque aliment est codé par une couleur différente. Trois choix d'affichage sont possibles : la répartition globale, dynamique ou par période. Ainsi, la quantité de chaque matière première utilisée peut être affichée.


Simulation simple (porc croissance): Dépôt de protéines

Dépôt de protéines

Ce graphique sert à identifier les facteurs susceptibles de limiter le dépôt de protéines pendant la simulation. Il diffère des autres graphiques car son affichage ne peut être que dynamique en fonction de l'âge ou du poids vif. Par défaut, le dépôt de protéines est affiché pour toute la durée de la simulation (courbe noire). La liste à gauche du graphique énumère les facteurs qui limitent potentiellement le dépôt de protéines. La liste est triée par ordre d'importance décroissante et est dépendante de chaque simulation (c.-à-d., l'ordre peut différer avec le changement d'animal ou de l'aliment). Les facteurs limitant réellement le dépôt de protéines pendant la simulation sont marqués par un astérisque. Le graphique de défaut montre le dépôt de protéine déterminé par ces facteurs limitants. La courbe noire, qui peut être cachée derrière d'autres courbes, représente le dépôt réel de protéine (c.-à-d., le minimum de tous les facteurs limitants).

Les facteurs limitants peuvent être sélectionnés par un clic gauche de souris, chacun génère un nouveau graphique présentant le dépôt de protéines permis par le facteur en question. Par exemple, l'apport de lysine peut limiter le dépôt de protéine pendant une partie de la simulation. La sélection de la lysine dans la liste proposée affichera le dépôt de protéines dans l'hypothèse où l'apport de lysine serait le facteur limitant (en plus du dépôt réel de protéine). La zone de recouvrement de la courbe lysine et de la courbe noire correspond alors à la période pendant laquelle la lysine limite réellement le dépôt de protéine.

Les courbes pour l'énergie et le dépôt protéique maximal (PDmax) peuvent se recouvrir à la fin de la simulation. Le recouvrement indique une consommation suffisante pour atteindre PDmax. Dans le cas contraire, le dépôt de protéines se situe sur la partie ascendante de la fonction curvilinéaire-plateau reliant l'apport d'énergie et le dépôt de protéines (voir également Loi de réponse à l'énergie)


Simulation simple (porc croissance): Acides aminés

Acides aminés

Ce graphique montre la répartition des acides aminés essentiels (y compris l'arginine) et de l'azote. La cystine pouvant être synthétisée à partir de la méthionine et la tyrosine à partir de la phénylalanine, les données relatives à ces acides aminés sont donc indiquées pour la somme de ces deux acides aminés.

Les graphiques présentant la répartition des acides aminés distinguent huit composants : l'indigestible, l'endogène basal, l'entretien, l'oxydation minimale, le dépôt, le déséquilibre, le déficit, et l'excès. La fraction non digestible correspond à la fraction qui échappe à la digestion iléale et elle inclut aussi la fraction de l'endogène spécifique (c-à-d., 100 moins la digestibilité iléale standardisée). Les valeurs de digestibilité iléale standardisée pour les matières premières sont celles des tables publiées par l'INRA-AFZ (Sauvant et al., 2004). Il en est de même pour la valeur de l'endogène basal qui varie en fonction de l'ingestion de matière sèche. L'entretien correspond à la perte d'acides aminés due au renouvellement des téguments (par exemple, les poils) et à la perte liée au turn-over minimal des acides aminés. Ces valeurs correspondent à celles publiées par Moughan (1999) et dépendent du poids vif à la puissance 0,75. On suppose qu'une fraction constante de l'apport en acides aminés au dessus du besoin de l'entretien sera oxydée (l'oxydation minimale). La valeur de cette fraction change selon les acides aminés et est calculée à partir du profil idéal d'acides aminés.

Le dépôt d'acides aminés dépend du dépôt de protéines et de son profil en acides aminés. Les trois autres composants (le déséquilibre, le déficit et l'excès) sont liés à une comparaison de l'apport en acides aminés, du dépôt réel de protéines et du dépôt de protéines dans le cas où l'apport de l'énergie limite de dépôt de protéine. Dans un premier temps, la différence est calculée entre l'apport d'un acide aminé disponible pour le dépôt et le dépôt de cet acide aminé quand l'apport énergétique est limitant. Le signe de cette valeur indique un excès (différence positive) ou un déficit (différence négative). Un autre acide aminé que celui étudié peut aussi limiter le dépôt de protéines. Le déséquilibre se rapporte alors à l'excès de l'acide aminé étudié qui n'a pu se déposer comme protéine (dans les conditions de la simulation) du fait d'un apport limitant en un autre acide aminé. En d'autres termes, le déséquilibre est la conséquence d'un apport excédentaire d'un acide relativement à l'apport déficitaire d'un autre acide aminé. Il est impossible d'avoir un excès et un déficit d'un même acide aminé en même temps. Cependant, un excès et un déficit peuvent apparaître sur un graphique de type "répartition globale", mais à des périodes de temps différentes. La quantité totale d'un acide aminé (dans le graphique "répartition globale") correspond à la somme de la quantité ingérée et du déficit produit durant la simulation. Le tableau ici dessus résume les aspects principaux de l'utilisation des acides aminés.

 | Desquamation | Turn-over minimal | Endogène basale | Composition du dépôt protéique | Protéine idéale | Rendement d'utilisation maximal
 | mg/kg PV0,75/j | mg/kg PV0,75/j | g/kg MS ingérée | % | % | %
Lysine | 4,5 | 23,9 | 0,313 | 6,96 | 100 | 72
Méthionine | 1,0 | 7,0 | 0,087 | 1,88 | 30 | 64
Cysétine | 4,7 | 4,7 | 0,140 | 1,03 | 30 | 37
Thréonine | 3,3 | 13,8 | 0,330 | 3,70 | 65 | 61
Tryptophane | 0,9 | 3,5 | 0,117 | 0,95 | 18 | 57
Isoleucine | 2,5 | 12,4 | 0,257 | 3,46 | 55 | 67
Leucine | 5,3 | 27,1 | 0,427 | 7,17 | 100 | 76
Valine | 3,8 | 16,4 | 0,357 | 4,67 | 70 | 71
Phénylalanine | 3,0 | 13,7 | 0,273 | 3,78 | 50 | 82
Tyrosine | 1,9 | 9,0 | 0,223 | 2,86 | 45 | 67
Histidine | 1,3 | 10,2 | 0,130 | 2,79 | 32 | 93
Arginine | 0,0 | 0,0 | 0,280 | 6,26 | 42 | 154
Protéine | 104,4 | 361,1 | 8,517 | - | - | 85

Le graphique "Apport et besoins" présente l'apport et les besoins sur la base de la digestibilité iléale standardisée ou apparente. L'apport total en acides aminés (mais pas les besoins) peut également être affiché. Les données peuvent être exprimés selon divers modes d'expression (g/j, relativement à lysine, g/MJ ED, g/MJ EM, g/MJ EN, g/kg ingéré, g/kg GMQ). Les besoins en acides aminés sont définis pour un apport en énergie limitant. Si dans la simulation le dépôt de protéines est limité par un apport insuffisant d'un acide aminé, la croissance est alors inférieure à ce qu'elle aurait dû être. Le besoin exprimé par kg de gain quotidien ne sera donc pas complètement exact, car le dénominateur reflète une croissance qui ne correspond pas aux besoins réels (c.-à-d., cas d'une situation limitante en énergie). Dans ce cas, le besoin sera affiché en pointillé.


Simulation simple (porc croissance): Énergie

Énergie

L'utilisation de l'énergie peut être exprimée sur une base d'EB, ED, EM ou EN. Les composantes de l'énergie sont l'indigestible (fécal), l'énergie perdue sous forme de méthane, l'énergie urinaire, l'énergie pour l'entretien (sans activité physique), l'énergie pour l'activité physique, l'extra-chaleur et l'énergie retenue sous forme de protéines ou de lipides. Les besoins pour l'entretien et l'activité physique sont exprimés en équivalent EM pour des valeurs affichées en EB, ED ou EM. La valeur EN exclue l'extra-chaleur pour l'entretien et l'activité physique. En conséquence, les teneurs en EN pour l'entretien et l'activité physique sont inférieures aux teneurs exprimées en EB, ED ou EM.

L'affichage du type "répartition de l'énergie retenue" sert à illustrer différentes théories sur la répartition de l'énergie (entre LD et PD). InraPorc est basé sur la théorie selon laquelle le PD marginal (c.-à-d., la variation de PD liée à clee de l'apport d'EN) diminue linéairement avec le poids vif (cf. Loi de réponse à l'énergie dans le profil animal pour plus de détails). D'autres théories sont basées sur la répartition de l'énergie destinée au PD (X, van Milgen et al., 2000), sur un rapport minimal entre LD et PD, sur un rapport marginal minimal entre LD et PD, ou sur un rapport minimal entre les masses de lipides et de protéines. Ces théories concernent la répartition de l'énergie et sont donc applicables uniquement quand l'apport énergétique (ou le génotype) limite les performances. Néanmoins, dans une simulation, les acides aminés peuvent aussi limiter les performances et modifier les réponses du porc à un changement de l'apport énergétique. Par conséquent, ces deux cas sont pris en compte.

Pour des raisons pratiques, il est souvent considéré que des valeurs énergétiques dépendent uniquement de l'aliment. Dans InraPorc, c'est le cas pour EB et ED, mais pas pour EM et EN. Par exemple, la valeur EM d'un aliment dépend (entre autres) de l'utilisation des protéines alimentaires pour le dépôt de protéines ; un dépôt faible de protéines augmente l'excrétion urinaire d'urée et réduit ainsi la valeur EM.

Le type de graphique "valeurs énergétiques" illustre la façon dont des valeurs énergétiques calculées (dépendant uniquement de l'aliment) et simulées (dépendant à la fois de l'aliment et de l'animal) changent au cours de la simulation. Les valeurs énergétiques peuvent être exprimées par jour, relativement au poids vif, par kg d'aliment ou par kg de gain quotidien.


Simulation simple (porc croissance): Minéraux

Minéraux

Ce graphique montre l'utilisation des minéraux pour différentes fonctions. Le phosphore est actuellement le seul minéral pris en compte. Le besoin en phosphore est basé sur l'approche factorielle et est exprimé sur la base de digestibilité apparente fécale (Jondreville et Dourmad, 2005). Le besoin (g/j) en phosphore endogène est calculé comme 0,01 · PV et la rétention de phosphore comme (5,4199 - 2 · 0,002857 · PV) · GMQ.

La fraction de phosphore indigestible dépend du type d'aliment, le traitement technologique (farine ou granulés) et l'utilisation de phytase microbienne. La phytase peut être inclue comme une matière première et doit être caractérisé par une valeur (d'équivalence) en phosphore digestible.

Il est possible que l'apport de phosphore soit insuffisant pour couvrir le besoin. Dans ce cas, le déficit sera affiché sur les graphiques, mais il n'aura pas des conséquences sur les performances simulées.


Simulation simple (porc croissance): Rétention et excrétion des minéraux

Rejets

Ce graphique indique la rétention et l'excrétion de N, P, Ca, K, Cu et Zn. Il est évident que cette information n'est pertinente que si la composition minérale des régimes est précise. Pour l'azote, la fraction excrétée est répartie entre les fractions urinaire et fécale. La rétention d'azote est calculée à partir de la rétention protéique et celle des autres minéraux à partir du poids vif (vide) (Dourmad et al., 2002, Jondrevillle and Dourmad, 2005).

P = 5,4199 · PV - 0,002857 · PV2
Ca = 8,64633 · PVV - 0,00180 · PVV2
K = 2,53338 · PVV - 0,00345 · PVV2
Cu = 2,8 + 1,05393 · PVV - 0,00251 · PVV2
Zn = 21,8 · PVV

Il est possible que l'apport minéral soit inférieur à la rétention calculée. Cependant dans la version actuelle d'InraPorc cela n'aura pas d'influence sur la croissance. Si un déficit survient, il sera indiqué simplement sur les graphiques.


Comparaison de simulations (porc croissance)

Comparaison de simulations

La comparaison de différentes simulations peut se faire soit par la comparaison des résultats de simulations simples, soit à partir d'une simulation de référence pour laquelle un paramètre sera modifié (ex. la séquence alimentaire). En cochant le bouton "Simulations simples", jusqu'à cinq simulations simples peuvent être sélectionnées à partir de listes. La case à droite de chaque liste permet l'affichage ou non des simulations. Si une autre case est cochée (ex. "Profil animal", "Séquence alimentaire" ou "Plan de rationnement"), une simulation de référence doit être sélectionnée. Le profil animal, la séquence alimentaire et le plan de rationnement de la simulation de référence sont alors appliqués. Cependant, un paramètre de cette simulation de référence peut être changé (ex. la "Séquence alimentaire"), les autres restants inchangés ("Profil animal" et "Plan de rationnement").

Un clic sur le bouton "Graphiques" lance les calculs et affiche les graphiques (performances, aliments, acides aminés, énergie et minéraux). Les graphiques sont définis par trois paramètres : le type de graphique, le variable de l'ordonné (Y) et le variable de l'abscisse (X). Selon l'onglet choisi, des listes sont proposées et les graphiques peuvent être configurés. L'impression d'un graphique se fait par un clic droit sur celui-ci. Un rapport succinct des simulations peut être obtenu en cliquant sur le bouton "Rapport".


Analyse de sensibilité (porc croissance)

Analyse de sensibilité

Une analyse de sensibilité nécessite le choix d'un profil de porc, d'une séquence alimentaire, d'un plan de rationnement et des critères définissant l'analyse de sensibilité. Ces caractéristiques concernent l'animal (PDmoyen, précocité, entretien et PV PDmax), la quantité d'aliment et l'apport en acides aminés. Elles sont modifiées relativement aux valeurs définies dans le profil animal, la séquence alimentaire et le plan de rationnement. Par défaut, les valeurs utilisées sont 90%, 95%, 100%, 105%, et 110% de celles définies. Le pourcentage définissant l'échelle de sensibilité peut être changée avec le bouton "variation".

Les calculs et l'affichage des graphiques (c.-à-d., performances, aliments, acides aminés, énergie et rejets) sont obtenus en cliquant sur le bouton "Graphiques". Les graphiques sont définis par trois paramètres : le type de graphique, le variable de l'ordonné (Y) et le variable de l'abscisse (X). Selon l'onglet choisi, les graphiques seront configurés en rapport avec les listes proposées. L'impression d'un graphique se fait par un clic droit sur celui-ci. Un rapport succinct des simulations peut être obtenu en cliquant sur le bouton "Rapport".


Comparaison de simulations (porc croissance): Performances

Performances

Des résultats de simulation peuvent être affichés dynamiquement ou globalement. Les options d'affichage concernent différents aspects du poids vif, temps, aliment distribué, efficacité alimentaire, les masses de protéines et de lipides et la qualité de carcasse.


Comparaison de simulations (porc croissance): Aliments

Aliments

Ce graphique présente les aliments utilisés (en quantité et en coût) pendant la simulation. Chaque aliment est codé par une couleur différente. En outre, la quantité de chaque matière première utilisée peut être affichée.


Comparaison de simulations (porc croissance): Acides aminés

Acides aminés

Ce graphique montre la répartition (moyenne) de l'utilisation des acides aminés essentiels et de l'azote entre différentes fonctions. Il peut aussi être utilisé pour afficher l'évolution au cours d'une simulation de l'apport ou du besoin en un acide aminé. Les besoins peuvent être exprimés sur la base de la digestibilité standardisée ou apparente. Ils peuvent être exprimés par jour, par kg d'aliment ou par kg du GMQ, relativement à la lysine ou par apport à l'énergie.


Comparaison de simulations (porc croissance): Énergie

Énergie

Ce graphe montre la répartition (moyenne) de l'utilisation de l'énergie pour différentes fonctions. L'énergie peut être exprimée sur une base de l'EB, de l'ED, de l'EM ou de l'EN. Ce graphe peut également être utilisé pour présenter l'évolution des valeurs énergétiques (calculées ou simulées) des régimes. Les valeurs énergétiques calculées dépendent seulement de la composition du régime de la digestibilité fécale. Les valeurs énergétiques simulées dépendent également de la manière dont l'animal utilise l'énergie. Dans la mesure où cette utilisation peut changer pendant une simulation, les valeurs énergétiques simulées ne sont donc pas constantes.


Comparaison de simulations (porc croissance): Minéraux

Minéraux

Ce graphique montre la répartition (moyenne) de l'utilisation des minéraux pour différentes fonctions. Le phosphore est actuellement le seul minéral considéré. L'apport ou le besoin de phosphore digestible peut être affiché en fonction du temps ou en fonction du poids vif pour les différentes simulations qui sont comparées.


Comparaison de simulations (porc croissance): Minéraux

Rejets

Ce graphique montre la rétention et l'excrétion (moyennes) de N, P, Ca, K, Cu et de Zn pour les différentes simulations qui sont comparées. Il est évident que cette information n'est pertinente que si la composition minérale des régimes est précise.


Une erreur s'est produite lors de l'importation de données pour la calibration

Plusieurs raisons peuvent expliquer que l'importation de données à partir d'un fichier CSV a échoué. Veuillez vérifier les aspects suivants :

  • Assurez-vous que le fichier CSV n'est pas ouvert par un autre logiciel (par exemple Excel)
  • Vérifiez que le fichier CSV contient une ligne d'en-tête avec 5 items, séparés par un séparateur de liste (cf. exemple ci-dessous)
  • Le symbole décimal et la séparateur de liste utilisés dans le fichier CSV doivent être identiques à ceux déclarés pour Windows (dans le Panneau de Configuration, Options Régionales et Linguistiques)
  • Il faut avoir un minimum de deux lignes de données (en plus de la ligne d'en-tête)
  • Vérifiez que les lignes de données ne contiennent que des données numériques
  • La première colonne du fichier (âge) ne doit contenir que des entiers positifs (par exemple 63, 64)

L'exemple ci-dessous montre le contenu d'un fichier CSV. Veuillez notez que les paramètres régionaux sont configurés pour utiliser le point-virgule (;) comme séparateur de liste et le point (.) comme symbole décimal. Le fichier CSV contient plusieurs champs vides pour l'épaisseur de lard dorsal et le TMP :

Age;Aliment distribué cumulé;Poids vif;Epaisseur de lard;TMP
60;0;25;;
117;99.7;64.9;;
182;268.7;120.1;;57.4


AJINOMOTO EUROLYSINE S.A.S.

InraPorc a été développé avec le soutien d'AJINOMOTO EUROLYSINE S.A.S.

AJINOMOTO EUROLYSINE S.A.S. produit et commercialise depuis 1976 des acides aminés obtenus par des procédés naturels de fermentation et destinés à l'alimentation animale.

AJINOMOTO EUROLYSINE S.A.S. est le premier producteur européen de lysine (100.000 tonnes/an en équivalent L-Lysine HCl), de thréonine (35.000 tonnes/an) et de tryptophane (1.300 tonnes/an). L'implantation de ses usines en France et en Italie ainsi que son réseau de distribution permettent à AJINOMOTO EUROLYSINE S.A.S. de fournir sur l'Europe continentale, l'Afrique, le Moyen-Orient et l'Asie centrale des produits et un service de qualité adaptés aux besoins de ses clients.

AJINOMOTO EUROLYSINE S.A.S.
153, rue de Courcelles
75817 Paris Cedex 17
France
Tel. : + 33 (0)1 44 40 12 12
Fax : + 33 (0)1 44 40 12 13
www.ajinomoto-eurolysine.com


Remerciements

Les concepts et l'interface l'utilisateur de InraPorc ont été testés avec l'aide de plusieurs sociétés, universités et organismes de développement, y compris:

Association Française de Zootechnie
16, rue Claude Bernard
75231 Paris Cedex 05
Tel. : +33 (0)1 44 08 17 71
www.zootechnie.fr
NV DANIS
Knijffelingstraat 15, 8851 Koolskamp, Belgium
Tel. : +32 (0)51-744951
www.danis.be
GROUPE GLON
BP 61, St Gérand, 56302 Pontivy Cedex, France
Tel. : +33 (0)2 97 28 39 39
www.groupe-glon.com
INZO°
BP 19, 02402 Chateau-Thierry cedex, France
Tel. : +33 (0)3 23 84 80 00
www.inzo-net.com
IFIP Institut du porc
La Motte au Vicomte, BP3, 35651 Le Rheu cedex, France
Tel. : +33 (0)2 99 60 98 20
www.ifip.asso.fr
PRIMEX SAS
La gare de Baud, BP 21, 56440 Languidic, France
Tel. : +33 (0)2 97 85 99 66
www.primex.fr


Erreurs dans les liens entre fichiers

Tous les fichiers de données utilisés dans InraPorc (avec l'extension *.rec) sont étroitement liés. Par exemple, une simulation est liée à une séquence alimentaire. Cette dernière est liée à un aliment qui, a son tour, peut être lié à des matières premières. Si pour quelque raison que ce soit un lien entre différents fichiers de données est corrompu, InraPorc ne peut pas fonctionner correctement.

Au démarrage du logiciel, la structure des données est entièrement vérifiée. Si des erreurs sont trouvées, elles sont listées dans une fenêtre. A titre d'exemple, nous supposerons qu'InraPorc a détecté une erreur dans une séquence alimentaire qui contient un lien vers un aliment non-existant. Dans le rapport d'erreur, le nom de la séquence alimentaire sera indiqué et nous proposerons de supprimer le lien corrompu. Si vous choisissez de ne pas le supprimer, vous ne pourrez pas travailler avec ce jeu de données et vous devrez trouver une solution par vous-même (par exemple, en restaurant les données à partir d'une sauvegarde). Si vous choisissez de le supprimer, le lien corrompu entre la séquence alimentaire (connue) et l'aliment (inconnu) sera supprimé et le rapport d'erreur sera sauvegardé dans le fichier Errors.log (situé dans le répertoire qui contient le jeu de données corrompu). Vous conserverez alors l'accès aux données et vous pourrez recréer le lien manquant manuellement (c.-à-d., en attribuant un nouvel aliment à la séquence alimentaire). L'information numérique concernant la séquence alimentaire (c.-à-d., le mode de la fin de la règle et de la quantité d'aliment) ayant été conservé, vous devrez seulement fournir un nouveau lien vers l'aliment que vous voulez utiliser. La séquence alimentaire corrompue ne sera pas disponible dans une simulation tant que le lien n'aura pas été corrigé.

Nous vous conseillons donc fortement de corrigez tous les liens corrompus avant de continuer à utiliser InraPorc.


INRA

INRA – Agrocampus : Unité Mixte de Recherche Systèmes d'Élevage, Nutrition Animale et Humaine (UMR SENAH)

L'Unité Mixte de Recherches "Systèmes d'Élevage, Nutrition Animale et Humaine" (UMR SENAH) a pour vocation de conduire des recherches finalisées pour répondre à la fois aux exigences de compétitivité des filières de production (élevage, alimentation animale, transformation) et aux attentes du consommateur et du citoyen (qualité, sécurité alimentaire, environnement, bien-être animal). Les objectifs principaux des recherches sont actuellement :

  • d'accroître la compétitivité des élevages en augmentant la valeur ajoutée
  • d'améliorer la qualité des produits
  • de proposer des systèmes d'élevage plus respectueux de l'environnement et du bien être animal

L'unité dispose de moyens expérimentaux pour les études physiologiques sur le porc et sur le veau, ainsi que d'installations expérimentales porcines (200 truies et leur production).
L'Institut National de la Recherche Agronomique (INRA), fondé en 1946, est un Établissement Public à caractère Scientifique et Technique (EPST) sous la double tutelle des Ministères en charge de la Recherche et l'Agriculture. L'INRA est chargé de :

  • œuvrer au service de l'intérêt public tout en maintenant l'équilibre entre les exigences de la recherche et les demandes de la société.
  • produire et diffuser des connaissances scientifiques et des innovations, principalement dans les domaines de l'agriculture, de l'alimentation et de l'environnement.
  • contribuer à l'expertise, à la formation, à la promotion de la culture scientifique et technique, au débat science/société.
L'Agrocampus Rennes rassemble plusieurs formations, 850 étudiants, 200 enseignants- chercheurs et personnels administratifs et techniques sur un campus de 17 ha. Membre de la Conférence des grandes écoles, Agrocampus Rennes développe 3 missions prioritaires : la formation initiale, la recherche et le développement.


Caractéristiques corporelles et de la carcasse

Pour les porcs en croissance, les caractéristiques corporelles et de la carcasse sont calculées toutes à partir des poids de protéines (P) et lipides (L) corporelles par des équation empiriques.

Poids vif vide (kg, PVV) = 5,969 · P0,944 + 0,854 · L0,944
Poids vif (kg, PV) = (PVV / 0,890)0,986

Le Taux de Muscle des Pièces (TMP), comme défini dans l'Union européenne (Règlement N° 1197/2006 de la Commission), est obtenue par régression entre la TMP estimée par la méthode de référence (Daumas et al., 1998) et la teneur de lipides dans le poids vif vide. Les données de cette rélation viennent de l'étude de Kloareg et al. (2006) :

Taux de Muscle des Pièces (TMP) = 57,43 + 95,68 · P / PVV - 62,68 · L / PVV

L'épaisseur de lard dorsal (mesurée à 6 cm de la ligne médiane dorsale entre les 3ème et 4ème dernières côtes à l'abattage) est estimée directement à partir du poids de lipides (Kloareg et al., 2006) :

épaisseur de lard dorsal (mm) = 6,96 + 0,375 · L

Les équations pour le TMP et l'épaisseur de lard dorsal peuvent être changées dans le menu de configuration d'InraPorc.

Pour les truies, l'épaisseur de lard dorsal est utilisée, avec le poids net, pour estimer la teneur corporelle en énergie et en protéines.


Présentation graphique des besoins pendant la lactation

Les principaux résultats sont représentés sous forme graphique. Le besoin calculé peut être comparé à l'apport réalisé par le plan d'alimentation sélectionné.

Aliment

Ce graphique permet d'afficher l'apport d'aliment recommandé pendant la lactation.

Énergie

Les besoins journaliers moyens pour l'entretien et la production laitière sont présentés sous forme graphique de façon à visualiser la contribution des différents types de dépenses énergétique au besoin total. L'affichage peut être réalisé en moyenne pour l'ensemble de la gestation ou de façon dynamique.

Acides aminés

Les besoins pour les différents acides aminés sont présentés sous la forme d'un histogramme. Un affichage dynamique de l'évolution des besoins des différents acides aminés avec le stade de lactation est également présenté et peut être comparé aux apports du plan d'alimentation. Différents modes d'expression des besoins peuvent être choisis (par jour, relativement à l'énergie, relativement à la lysine, ...).


Présentation graphique des besoins pendant la gestation

Les principaux résultats sont représentés sous forme graphique. Le besoin calculé peut être comparé à l'apport réalisé par le plan d'alimentation sélectionné.

Aliment

Ce graphique permet d'afficher l'apport moyen d'aliment recommandé pendant la gestation. Par défaut, l'apport est supposé constant sur l'ensemble de la période. Mais il est possible de calculer l'apport dans le cas d'une répartition différente de la même quantité d'aliment ; par exemple dans le cas d'une suralimentation en début ou en fin de gestation. Dans ce cas la gestation est séparée en 3 phases dont on doit définir la durée et les niveaux d'apports.

Énergie

Les besoins journaliers moyens pour l'entretien, la thermorégulation, l'activité et le développement de la portée sont présentés sous forme graphique de façon à visualiser la contribution des différents types de dépenses énergétique au besoin total. L'affichage peut être réalisé en moyenne pour l'ensemble de la gestation ou de façon dynamique. Dans certains cas (truies âgées en bon état corporel) il se peut qu'en fin de gestation, l'apport moyen calculé ne soit pas suffisant pour couvrir les dépenses prioritaires. Dans ce cas il est recommandé de modifier la répartition des apports au cours de la gestation (diminuer au début et augmenter à la fin) de façon à couvrir ces dépenses prioritaires jusque la fin de la gestation (voir paragraphe ci-dessus). Lorsque l'on a spécifié un plan d'alimentation de référence, l'apport permis par ce plan est affiché sur le graphique, ce qui permet de le comparer aux besoins de l'animal considéré.

Acides aminés

Les besoins pour les différents acides aminés, à 30 et à 105 jours de gestation, sont présentés sous la forme d'un histogramme. Un affichage dynamique de l'évolution des besoins des différents acides aminés avec le stade de gestation est également présenté et peut être comparé aux apports du plan d'alimentation. Différents modes d'expression des besoins peuvent être choisis (par jour, relativement à l'énergie, relativement à la lysine, ...).